Bug 60217 - /etc/screenrc not read
/etc/screenrc not read
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: screen (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Phil Copeland
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-02-22 04:27 EST by David Balažic
Modified: 2007-04-18 12:40 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-27 06:47:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Balažic 2002-02-22 04:27:29 EST
Description of Problem:

Looks like /etc/screenrc is not read.
screen  version is 3.9.10-1

Version-Release number of selected component (if applicable):

screen-3.9.10-1

How Reproducible:

Always. Run screen on VT1 , press BACKSPACE, it should be translated
to ^H  due to aline in /etc/screenrc, but it is not.

Steps to Reproduce:
1.  see above
2. 
3. 

Actual Results:


Expected Results:


Additional Information:

Might be a problem in the spec file :

sed -e 's/.*#.*undef.*HAVE_BRAILLE.*/#define HAVE_BRAILLE 1/;
        s/.*#.*undef.*BUILTIN_TELNET.*/#define BUILTIN_TELNET 1/;
        s/\(#.*define.*ETCSCREENRC.*\)"\/usr\/etc\/screenrc"/
\1"\/etc\/screenrc"/;' < config.h > config.tmp.h

What is the \( \) pair for ?
Comment 1 David Balažic 2002-03-27 06:47:54 EST
The problem went away with screen-3.9.11-1

Note You need to log in before you can comment on or make changes to this bug.