Bug 60219 - Gets errors when starting xinetd
Gets errors when starting xinetd
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: kdenetwork (Show other bugs)
7.3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-02-22 07:09 EST by Mike Chambers
Modified: 2007-04-18 12:40 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-03 01:04:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike Chambers 2002-02-22 07:09:52 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; Q312461)

Description of problem:
When starting or restarting xinetd, I get errors on talk and ntalk even if 
disabled.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.service xinetd start
2.service xinetd restart
3.
	

Actual Results:  Feb 21 06:55:28 homer xinetd[19851]: Service talk: missing '{' 
[line=5]
Feb 21 06:55:28 homer xinetd[19851]: Service ntalk: missing '{' [line=5]


Expected Results:  talk and ntalk should not error.

Additional info:

This is an update from 7.2 to 7.2.90.  Xinetd seems to work fine with exception 
of the two errors above.
Comment 1 Trond Eivind Glomsrxd 2002-03-01 12:00:36 EST
This looks very much like a configuration issue with the talk and ntalk
services... how do they look?
Comment 2 Mike Chambers 2002-03-01 14:18:50 EST
I don't use either one of these and they are disabled as you can see, but 
thought I would still report them.   I haven't touched the config files since 
installing 7.2 so these are as in version the install and upgrade.  Here are 
the talk and ntalk config files from /etc/xinetd.d/ directory...

[root@homer xinetd.d]# more talk
# default: off
# description: The talk server accepts talk requests for chatting with users \
#       on other systems.
service talk
{
        disable = yes
        socket_type             = dgram
        wait                    = yes
        user                    = nobody
        group                   = tty
        server                  = /usr/sbin/in.talkd
}
[root@homer xinetd.d]# more ntalk
# default: off
# description: The ntalk server accepts ntalk connections, for chatting \
#       with users on different systems.
service ntalk
{
        disable = yes
        socket_type             = dgram
        wait                    = yes
        user                    = nobody
        group                   = tty
        server                  = /usr/sbin/in.ntalkd
}
Mar  1 12:50:54 homer xinetd[25642]: Service talk: missing '{' [line=5]
Mar  1 12:50:54 homer xinetd[25642]: Service ntalk: missing '{' [line=5]

I reinstalled both from hampton beta1 cd and still get above..

[root@homer xinetd.d]# rpm -q talk talk-server
talk-0.17-13
talk-server-0.17-13
Comment 3 Mike Chambers 2002-03-12 10:06:54 EST
I haven't seen any errors so far in beta-2 so maybe this is fixed?

[reddawg@homer reddawg]$ rpm -q xinetd
xinetd-2.3.4-0.5
Comment 4 Jay Turner 2002-03-20 10:38:01 EST
Closing out, as I can't reproduce either.
Comment 5 Mike Chambers 2002-03-22 07:28:00 EST
This bug still exists in beta 3, skipjack.  This is on a fresh install.
Neither ntalk nor talk are active/on.
Comment 6 Michael Fulbright 2002-03-25 16:29:17 EST
What does 'rpm -V talk ntalk' say?
Comment 7 Mike Chambers 2002-03-25 20:39:10 EST
[reddawg@homer reddawg]$ rpm -V talk
[reddawg@homer reddawg]$ rpm -V ntalk
package ntalk is not installed

Not installed on a "complete/full install"?
Comment 8 Trond Eivind Glomsrxd 2002-03-26 15:52:56 EST
This isn't an xinetd problem... it's  /etc/xinetd.d/k{,o}talk which provides the
same services but don't have a newline after the service name. That's why there
are errors when the ntalk/talk files look just fine.
Comment 9 Mike Chambers 2002-03-26 18:17:44 EST
Ok, I saw where the starting { needed to be moved down one line on ktalk and 
kotalk which both actually point to talk and ntalk binaries.  I restarted and 
didn't see the error.  So ktalkd rpm coming from kdenetwork is the component 
behidn this and now it's reassigned to Bero?
Comment 10 Trond Eivind Glomsrxd 2002-03-26 18:55:55 EST
Yes
Comment 11 R P Herrold 2002-04-03 01:04:24 EST
Bugs are still present in ktalkd-3.0.0-0.cvs20020321.1 -- which is produced from
kdenetwork

-- This looks like a two character fix -- a CR before the opentin "{" in teh
ktalk and kotalk files ...

[root@couch xinetd.d]# nl ktalk
     1  # default: off
     2  # description: KDE version of the talk server (accepting talk requests
     3  #              for chatting with users on other systems).
     4  service ntalk {
     5          disable         = yes
     6          socket_type     = dgram
     7          wait            = yes
     8          user            = root
     9          group           = tty
    10          server          = /usr/bin/ktalkd
    11  }
[root@couch xinetd.d]# nl kotalk
     1  # default: off
     2  # description: KDE version of the talk server (accepting talk requests
     3  #              for chatting with users on other systems).
     4  service talk {
     5          disable         = yes
     6          socket_type     = dgram
     7          wait            = yes
     8          user            = root
     9          group           = tty
    10          server          = /usr/bin/kotalkd
    11  }
[root@couch xinetd.d]# ls
chargen      daytime      echo-udp  rsync     sgi_fam
chargen-udp  daytime-udp  kotalk    servers   time
cvspserver   echo         ktalk     services  time-udp
[root@couch xinetd.d]# cat chargen
# default: off
# description: A chargen server. This is the tcp \
# version.
service chargen
{
        disable = yes
        type            = INTERNAL
        id              = chargen-stream
        socket_type     = stream
        protocol        = tcp
        user            = root
        wait            = no
}
[root@couch xinetd.d]# service xinetd restart
Stopping xinetd:                                           [  OK  ]
Starting xinetd:                                           [  OK  ]
[root@couch xinetd.d]# tail /var/log/messages
Apr  3 00:52:30 couch xinetd[11732]: xinetd Version 2002.02.28-1 started with
libwrap options compiled in.
Apr  3 00:52:30 couch xinetd[11732]: Started working: 2 available services
Apr  3 00:52:32 couch xinetd: xinetd startup succeeded
Apr  3 00:54:54 couch xinetd[11732]: Exiting...
Apr  3 00:54:54 couch xinetd: xinetd shutdown succeeded
Apr  3 00:54:54 couch xinetd[11774]: Service talk: missing '{' [line=5]
Apr  3 00:54:54 couch xinetd[11774]: Service ntalk: missing '{' [line=5]
Apr  3 00:54:55 couch xinetd[11774]: xinetd Version 2002.02.28-1 started with
libwrap options compiled in.
Apr  3 00:54:55 couch xinetd[11774]: Started working: 2 available services
Apr  3 00:54:57 couch xinetd: xinetd startup succeeded
[root@couch xinetd.d]# rpm -qf kotalk ktalk
ktalkd-3.0.0-0.cvs20020321.1
ktalkd-3.0.0-0.cvs20020321.1
[root@couch xinetd.d]# rpm -qi ktalkd
Name        : ktalkd                       Relocations: /usr
Version     : 3.0.0                             Vendor: Red Hat, Inc.
Release     : 0.cvs20020321.1        Build Date: Thu 21 Mar 2002 02:06:46
PM EST
Install date: Tue 02 Apr 2002 12:11:14 AM EST      Build Host:
daffy.perf.redhat.com
Group       : Applications/Internet         Source RPM:
kdenetwork-3.0.0-0.cvs20020321.1.src.rpm
Size        : 258510                           License: GPL
Packager    : Red Hat, Inc. <http://bugzilla.redhat.com/bugzilla>
Summary     : Talk (chat) protocol implementation for KDE
Description :
An implementation of the Talk protocol for KDE.
[root@couch xinetd.d]#

Note You need to log in before you can comment on or make changes to this bug.