Bug 602215 - Reservation emails should be more Beaker-friendly
Reservation emails should be more Beaker-friendly
Status: CLOSED CURRENTRELEASE
Product: Beaker
Classification: Community
Component: tests (Show other bugs)
0.5
All Linux
medium Severity medium (vote)
: ---
: ---
Assigned To: Bill Peck
:
: 603757 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-09 08:18 EDT by David Kovalsky
Modified: 2014-03-31 19:45 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-13 20:14:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Marian Csontos 2010-06-09 08:43:07 EDT
This is to be filled in against reservesys test as it is the reservesys which needs to be adapted a bit, but I do not mind making the changes...

RESULT_SERVER is a proxy running on a lab machine (or system as they are called now)

There is one problem: LM's have no access to Scheduler (actually, they do not know about it.)

This is the only thing which should be raised against beaker. Bill, could you export it in job XML please?
Comment 2 Marian Csontos 2010-06-11 09:00:54 EDT
Took this as a relax item ;-)

Re: changing From/Subject: though it makes sense, if anyone uses this in a script, it will break them.
Comment 3 David Kovalsky 2010-06-11 09:16:46 EDT
I think it's pretty hard to do filtering by the subject if you only have a redhat.com FQDN :) But agreed, the possibility is there. 

For making filtering easier, you could also add more information as email headers. for example, X-BEAKER-JOBID: 2418, X-BEAKER-ACTION: reservsys, etc...

With one value per header is should be way easier to setup automatic filtering.
Comment 4 Marian Csontos 2010-06-11 10:06:32 EDT
FYI, there is already X-RHTS-test header

But I agree.

I am going on...
Comment 5 Kevin Baker 2010-06-11 10:59:35 EDT
(In reply to comment #4)
> FYI, there is already X-RHTS-test header

We should standardies the naming. I'm asking the guys to s/rhts/beaker/ elsewhere so these should be consistent too.

X-Beaker-<key> <value>
Comment 6 Marian Csontos 2010-06-14 10:28:13 EDT
*** Bug 603757 has been marked as a duplicate of this bug. ***
Comment 7 Marian Csontos 2010-06-17 15:02:50 EDT
Fixed by rh-tests-distribution-reservesys-2.0-44

I need variable with scheduler's URL. Could you sent it out in XML?

Assign back to me afterwards please
Comment 8 Dan Callaghan 2012-08-13 20:14:14 EDT
All the suggestions in this bug have made it into the latest version of Beaker and /distribution/reservesys.

Note You need to log in before you can comment on or make changes to this bug.