Bug 60228 - as coredumps building 2.4.18-rc2-ac2
Summary: as coredumps building 2.4.18-rc2-ac2
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: binutils (Show other bugs)
(Show other bugs)
Version: 1.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-02-22 15:39 UTC by Jonathan Kamens
Modified: 2008-05-01 15:38 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-02-25 10:42:03 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jonathan Kamens 2002-02-22 15:39:05 UTC
root@jik:/d/kernel/2.4.18-rc2-ac2/arch/i386/kernel!28# gcc -D__ASSEMBLY__
-D__KERNEL__ -I/d/kernel/2.4.18-rc2-ac2/include -traditional -c entry.S
gcc: Internal error: Segmentation fault (program as)
Please submit a full bug report.
See <URL:http://bugzilla.redhat.com/bugzilla/> for instructions.
root@jik:/d/kernel/2.4.18-rc2-ac2/arch/i386/kernel!29# rpm -q -f /usr/bin/as
binutils-2.11.93.0.2-3
root@jik:/d/kernel/2.4.18-rc2-ac2/arch/i386/kernel!30#

Comment 1 Jakub Jelinek 2002-02-22 17:46:49 UTC
Suspect the glibc bug as well.

Comment 2 Jonathan Kamens 2002-02-24 23:46:44 UTC
This problem does NOT go away when I upgrade to glibc-2.2.90-7.


Comment 3 Jakub Jelinek 2002-02-25 10:12:59 UTC
Reproduced, but looks like a glibc bug anyway (I had glibc-2.2.5-something
installed and as worked, after upgrade to 2.2.90-7 it started segfaulting).

Comment 4 Jakub Jelinek 2002-02-25 10:41:59 UTC
Simplified into small testcase showing mmap stdio ungetc bug, working on it.

Comment 5 Jakub Jelinek 2002-03-04 16:02:48 UTC
Should be fixed in glibc-2.2.90-8.


Note You need to log in before you can comment on or make changes to this bug.