Bug 602283 - Unable to install VP6 codec
Unable to install VP6 codec
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: totem (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-09 10:20 EDT by Michael Monreal
Modified: 2010-06-10 05:58 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-10 05:58:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Monreal 2010-06-09 10:20:13 EDT
I tried to play a .flv file (flash video) using totem and it told me that it needs a plugin for "On2 VP6/Flash decoder". It was unable to find one.

The needed plugin is available in gstreamer-ffmepg. The rpmfusion repo is enabled and I think the codec installer also pulls in -bad and -ugly plugin packages, so why not -ffmpeg?
Comment 1 Bastien Nocera 2010-06-09 11:43:48 EDT
In the Totem command-line output, you'll see which exact codec is missing.

Then you can do something like:
yum whatprovides "gstreamer0.10(decoder-video/x-vp6)()(64bit)"

If it's empty, then RPMFusion isn't properly set up, or yum has problems. If it does show something, then it's PackageKit's fault.
Comment 2 Michael Monreal 2010-06-09 14:54:01 EDT
Totem shows this:

** Message: PackageKit: structure: gstreamer0.10(decoder-video/x-vp6-flash)

After that I tried

[mimox ~]$ yum whatprovides "gstreamer0.10(decoder-video/x-vp6-flash)"
Loaded plugins: presto, refresh-packagekit
Warning: 3.0.x versions of yum would erroneously match against filenames.
 You can use "*/gstreamer0.10(decoder-video/x-vp6-flash)" and/or "*bin/gstreamer0.10(decoder-video/x-vp6-flash)" to get that behaviour
No Matches found

and

[mimox ~]$ yum whatprovides "gstreamer0.10(decoder-video/x-vp6-flash)()(32bit)"
Loaded plugins: presto, refresh-packagekit
Warning: 3.0.x versions of yum would erroneously match against filenames.
 You can use "*/gstreamer0.10(decoder-video/x-vp6-flash)()(32bit)" and/or "*bin/gstreamer0.10(decoder-video/x-vp6-flash)()(32bit)" to get that behaviour
No Matches found

not 100% sure about the syntax here but I guess the last one should have shown a package?

SPEC file => http://cvs.rpmfusion.org/viewvc/rpms/gstreamer-ffmpeg/F-13/gstreamer-ffmpeg.spec?revision=1.14&root=free&view=markup

what exactly is missing?
Comment 3 Bastien Nocera 2010-06-09 16:51:55 EDT
Try:
yum whatprovides "gstreamer0.10(decoder-video/x-vp6-flash)()"
"(64bit)" is appended for 64bit systems.

$ rpm -q --provides gstreamer-ffmpeg | grep vp6
gstreamer0.10(decoder-video/x-vp6)()(64bit)  
gstreamer0.10(decoder-video/x-vp6-alpha)()(64bit)  
gstreamer0.10(decoder-video/x-vp6-flash)()(64bit)  

So should work on a 32-bit system.
Comment 4 Michael Monreal 2010-06-09 17:08:04 EDT
$ yum whatprovides "gstreamer0.10(decoder-video/x-vp6-flash)()"
Loaded plugins: presto, refresh-packagekit
Warning: 3.0.x versions of yum would erroneously match against filenames.
 You can use "*/gstreamer0.10(decoder-video/x-vp6-flash)()" and/or "*bin/gstreamer0.10(decoder-video/x-vp6-flash)()" to get that behaviour
No Matches found

And

$ rpm -q --provides gstreamer-ffmpeg | grep vp6

returns nothing (after manually reinstalling gstreamer-ffmpeg)
Comment 5 Bastien Nocera 2010-06-10 05:58:11 EDT
It's a bug in the RPMFusion package then, which might be due to a bug in our gstreamer.prov, but the RPMFusion guys will file a separate bug if that's the case.

Note You need to log in before you can comment on or make changes to this bug.