This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 602312 - RFE: Allows alphabet characters in <productnumber>
RFE: Allows alphabet characters in <productnumber>
Status: CLOSED CURRENTRELEASE
Product: Publican
Classification: Community
Component: publican (Show other bugs)
1.6
All Linux
low Severity medium
: ---
: ---
Assigned To: Jeff Fearn
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-09 11:17 EDT by Deon Ballard
Modified: 2010-11-23 23:20 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-21 23:46:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Deon Ballard 2010-06-09 11:17:28 EDT
It would be nice if <productnumber> allowed alphabet characters so that I can use "beta" and "alpha" in the title of the book.
Comment 1 Ruediger Landmann 2010-06-09 16:40:20 EDT
It already does. Just make sure that you set a "version:" in the publican.cfg file that meets RPM package name requirements for a version (ie, only digits and a dot).

From the Publican User Guide, 3.1.2. Book_Info.xml, describing the <productnumber> tag:

"Override this tag with the version  variable in the publican.cfg file if the product version is anything other than a number. "
Comment 2 Deon Ballard 2010-06-16 16:33:16 EDT
Actually, version: in publican.cfg does exactly the same as <productnumber>. It allows numbers and a period.

The RFE is to allow alphabet characters in some way. For example, I would like to be able to have the top heading in the index.html be...

JBoss Operations Network 2.4 Beta

Right now, that is not possible because the 2.4 part comes from either version: or <productnumber>, neither of which allow an additional "Beta" after the number.

So, the RFE is to allow alphabet characters OR to add a new optional field that would allow someone to append Alpha or Beta to the product name.
Comment 3 Jeff Fearn 2010-06-16 20:59:23 EDT
(In reply to comment #2)
> Actually, version: in publican.cfg does exactly the same as <productnumber>. It
> allows numbers and a period.
> 
> The RFE is to allow alphabet characters in some way. For example, I would like
> to be able to have the top heading in the index.html be...
> 
> JBoss Operations Network 2.4 Beta
> 
> Right now, that is not possible because the 2.4 part comes from either version:
> or <productnumber>, neither of which allow an additional "Beta" after the
> number.
> 
> So, the RFE is to allow alphabet characters OR to add a new optional field that
> would allow someone to append Alpha or Beta to the product name.    

If you set product/version/release in the publican.cfg file, then you can put anything you like in the corresponding fields in the XML as they will no longer be validated for packaging use.

The settings in publican.cfg will be used for packaging and the content in the XML will be used for display.

e.g.

If you set "version: 2.4" in publican.cfg then you can put "<productnumber>2.4 GAMMA</productnumber>" in the XML, " 2.4 GAMMA" will appear in the output wherever you'd expect to see the product number displayed, however the package will be build using "2.4" as the version.

Note You need to log in before you can comment on or make changes to this bug.