Bug 602351 - PartitionException: Attempting to remove a partition that is not owned by any disk.
PartitionException: Attempting to remove a partition that is not owned by any...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: anaconda (Show other bugs)
6.0
x86_64 Linux
medium Severity medium
: rc
: ---
Assigned To: David Lehman
Release Test Team
anaconda_trace_hash:747baf7b3fcdad8fc...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-09 12:51 EDT by Jeff Bastian
Modified: 2010-11-10 14:47 EST (History)
3 users (show)

See Also:
Fixed In Version: anaconda-13.21.51-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-10 14:47:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (928.52 KB, text/plain)
2010-06-09 12:52 EDT, Jeff Bastian
no flags Details
Attached traceback automatically from anaconda. (193.65 KB, text/plain)
2010-06-09 13:23 EDT, Jeff Bastian
no flags Details
updates against anaconda-13.21.50-1 for 602351 (120.91 KB, application/octet-stream)
2010-06-09 14:13 EDT, David Lehman
no flags Details

  None (edit)
Description Jeff Bastian 2010-06-09 12:51:58 EDT
The following was filed automatically by anaconda:
anaconda 13.21.50 exception report
Traceback (most recent call first):
  File "/usr/lib64/python2.6/site-packages/parted/disk.py", line 269, in removePartition
    if self.__disk.remove_partition(partition.getPedPartition()):
  File "/usr/lib64/python2.6/site-packages/parted/decorators.py", line 31, in localeC
    ret = fn(*args, **kwds)
  File "<string>", line 2, in removePartition
  File "/usr/lib/anaconda/storage/formats/disklabel.py", line 277, in removePartition
    self.partedDisk.removePartition(partition)
  File "/usr/lib/anaconda/storage/devices.py", line 1352, in destroy
    self.disk.originalFormat.removePartition(self.partedPartition)
  File "/usr/lib/anaconda/storage/deviceaction.py", line 218, in execute
    self.device.destroy()
  File "/usr/lib/anaconda/storage/devicetree.py", line 705, in processActions
    action.execute(intf=self.intf)
  File "/usr/lib/anaconda/storage/__init__.py", line 293, in doIt
    self.devicetree.processActions()
  File "/usr/lib/anaconda/packages.py", line 109, in turnOnFilesystems
    anaconda.id.storage.doIt()
  File "/usr/lib/anaconda/dispatch.py", line 208, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 126, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/gui.py", line 1335, in nextClicked
    self.anaconda.dispatch.gotoNext()
PartitionException: Attempting to remove a partition that is not owned by any disk.
Comment 1 Jeff Bastian 2010-06-09 12:52:01 EDT
Created attachment 422619 [details]
Attached traceback automatically from anaconda.
Comment 2 Jeff Bastian 2010-06-09 12:54:27 EDT
I told anaconda to use the entire 320GB disk and create the following partitions:
  sda1 - 500MB for /boot
  sda2 - rest of disk for LVM VG
    lvm lv_root - 250GB for /
    lvm lv_swap - 4GB
    remainder is free space for future use
Comment 3 Jeff Bastian 2010-06-09 13:03:32 EDT
Oh, I may have caused this problem.  I was trying to preserve some existing LVM logical volumes but anaconda was not showing my existing partitioning scheme with any of the options.  So I switched to a shell (ALT-F2) and ran
   lvm vgscan
   lvm vgchange -ay
   lvm lvdisplay

Then I went back to anaconda to see if it would show my existing setup, but no luck.


So I rebooted and started from scratch and it worked fine when I didn't mess with LVM behind the scenes. :)
Comment 4 Jeff Bastian 2010-06-09 13:23:49 EDT
Created attachment 422628 [details]
Attached traceback automatically from anaconda.
Comment 5 Jeff Bastian 2010-06-09 13:27:31 EDT
My second attempt made it past the partitioning (as I mentioned in comment 3), but it failed a short bit later when it complained that it couldn't find the .treeinfo file on the DVD.  (I burned a DVD of RHEL6.0-20100603.1-Workstation-x86_64-DVD1.iso and I'm installing from that.)

So I rebooted and let the DVD do a self-check (which passed).  But my 3rd attempt failed again on the partitioning with the same error as the 1st attempt (and I did NOT do any manual 'lvm' commands this time).

Let me try a 4th time...
Comment 6 Jeff Bastian 2010-06-09 13:39:25 EDT
The 4th attempt made it past the partitioning, but ran into the same problem as the 2nd attempt:
               Error
  Unable to read group information from repositories.  This
  is a problem with the generation of your install tree.
         [ Exit installer]  [ Retry ]

Retrying doesn't fix the problem.

I'll gather the logs and open a new bug for this problem.
Comment 7 Jeff Bastian 2010-06-09 13:49:36 EDT
See bug 602369 for the "unable to read group information" problem.
Comment 8 David Lehman 2010-06-09 14:13:25 EDT
Created attachment 422638 [details]
updates against anaconda-13.21.50-1 for 602351

Please try the attached updates.img and see if it resolves the problem. Instructions for specifying the updates image can be found here: https://fedoraproject.org/wiki/Anaconda/Updates#Updates_from_the_Network
Comment 9 Jeff Bastian 2010-06-09 15:22:11 EDT
That seemed to do the trick!  The installation proceeded with the updates.img from comment 8.

I also had to install over http instead of from the DVD to workaround bug 602369.  Apparently it's only the repos on the DVD that are corrupt.

Thanks for the quick response!
Comment 11 Alexander Todorov 2010-07-06 05:19:33 EDT
Jeff,
can you re-test this with snapshot #7 or post more detailed steps to reproduce?
Comment 12 Jeff Bastian 2010-07-06 12:20:55 EDT
I don't have easy access to the system at the moment to try snapshot 7, so here's what I did.

I just tried to do an installation of RHEL 6 20100603.1 using the GUI installer.  The system was a simple desktop PC with a single SATA disk (i.e., nothing fancy).  It was running RHEL 5.6 with a fairly standard partition scheme:
   /dev/sda1    /boot    (200 MB)
   /dev/sda2    LVM      (rest of disk)
      lv_root   /        160GB  
      lv_swap   (swap)   4GB
and a few more logical volumes used for virtual machines.

I just followed the steps through the anaconda gui and it crashed with the above error when it tried to partition the disk.

As I mentioned in comment 9, though, the updates.img fixed the problem for me.
Comment 13 Alexander Todorov 2010-07-20 07:51:42 EDT
Tested with snap #8 (0715.0)

1st install)
   /dev/vda1    /boot    (200 MB)
   /dev/vda2    LVM      (rest of disk)
      lv_root   /        2GB  
      lv_swap   (swap)   1GB
      and 4 more logical volumes (not mounted)

2nd install)
Told anaconda "Use all space" and "Review partitioning" then decreased size for lv_root to create some free space in the VG and proceeded.

No traceback, install completed, system boots. Moving to VERIFIED.
Comment 14 releng-rhel@redhat.com 2010-11-10 14:47:29 EST
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.