Bug 60242 - Hampton install hangs loading sym53c8xx module during install on Dell PE 8450
Hampton install hangs loading sym53c8xx module during install on Dell PE 8450
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ben LaHaise
Brian Brock
:
: 60367 (view as bug list)
Depends On:
Blocks: 61590
  Show dependency treegraph
 
Reported: 2002-02-22 12:45 EST by John A. Hull
Modified: 2007-04-18 12:40 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-17 13:46:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmidecode (24.65 KB, text/plain)
2002-02-22 12:48 EST, John A. Hull
no flags Details
mptable output (30.60 KB, text/plain)
2002-02-22 12:49 EST, John A. Hull
no flags Details
pirq dump (3.76 KB, text/plain)
2002-02-22 12:50 EST, John A. Hull
no flags Details

  None (edit)
Description John A. Hull 2002-02-22 12:45:46 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows NT 5.0; DigExt)

Description of problem:
Hampton installs hang loading sym53c8xx module during the installation on the 
Dell PowerEdge 8450. Passing "linux apic" to the kernel resolves the problem. 


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Boot to Hampton CD or bootnet disk on PE 8450
2. Module will hang
3.
	

Actual Results:  module hangs

Expected Results:  Shouldn't hang, and shouldn't have to pass apic to the kernel

Additional info:
Comment 1 John A. Hull 2002-02-22 12:48:22 EST
Created attachment 46403 [details]
dmidecode
Comment 2 John A. Hull 2002-02-22 12:49:39 EST
Created attachment 46404 [details]
mptable output
Comment 3 John A. Hull 2002-02-22 12:50:12 EST
Created attachment 46405 [details]
pirq dump
Comment 4 Bob Matthews 2002-03-11 15:54:35 EST
I believe this might be the culprit:

[root@machiney]# rpm -ivh kernel-bigmem-2.4.18-0.1.i686.rpm
Preparing...                ########################################### [100%]
   1:kernel-bigmem          ########################################### [100%]
/sbin/mkinitrd: [:
/lib/modules/2.4.18-0.1bigmem/./kernel/drivers/scsi/sym53c8xx_2/sym53c8xx.o:
binary operator expected
Comment 5 Nils Philippsen 2002-03-14 09:25:16 EST
This is still the case with 2.4.18-0.4.

The problem is that there are two modules named sym53c8xx.o, the "original" one
(kernel/drivers/scsi/sym53c8xx.o) and the new(?) one
(kernel/drivers/scsi/sym53c8xx_2/sym53c8xx.o).

This obviously confuses mkinitrd because it finds two modules named 53c8xx. It
possibly even confuses modprobe and users -- surely it is b*tt ugly and therefore
the new one should just be called sym53c8xx_2 or similar.
Comment 6 Michael K. Johnson 2002-03-14 10:13:38 EST
Ben, can you please take care of this one real quick since
Arjan is not around today?  Just call the new module sym53c8xx_2.
Thanks
Comment 7 Ben LaHaise 2002-03-14 22:06:21 EST
A fix is now in CVS.
Comment 8 Jay Turner 2002-03-20 21:05:31 EST
*** Bug 60367 has been marked as a duplicate of this bug. ***
Comment 9 Dean Oliver 2002-03-25 15:14:17 EST
This problem still exists in hampton beta 3.
Still need to pass "linux apic" or cannot install 
due to driver constantly resetting.
Comment 10 Michael K. Johnson 2002-03-26 14:29:01 EST
Please post dmidecode information for this particular BIOS, looks like
another one for the blacklist.
Comment 11 John A. Hull 2002-03-27 14:32:11 EST
See attachments for this bugzilla. Dmidecode already there.
Comment 12 John A. Hull 2002-04-17 10:57:07 EDT
Is this going to be blacklisted for gold?
Comment 13 Arjan van de Ven 2002-04-17 13:46:25 EDT
Time to ask your money back from Intel for the bios...
Comment 14 John A. Hull 2002-04-29 16:28:02 EDT
Fixed in Hampton Gold

Note You need to log in before you can comment on or make changes to this bug.