Bug 60245 - mozilla SEGFAULTs
mozilla SEGFAULTs
Status: CLOSED WORKSFORME
Product: Red Hat Raw Hide
Classification: Retired
Component: mozilla (Show other bugs)
1.0
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Christopher Blizzard
Ben Levenson
:
: 60256 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-02-22 14:04 EST by Mario Mikocevic
Modified: 2007-04-18 12:40 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-08 20:15:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mario Mikocevic 2002-02-22 14:04:39 EST
Description of Problem:
# cat /etc/redhat-release 
Raw Hide 20020220


lstat64("/usr", {st_mode=S_IFDIR|0755, st_size=4096, ...}) = 0
lstat64("/usr/lib", {st_mode=S_IFDIR|0755, st_size=32768, ...}) = 0
lstat64("/usr/lib/mozilla", {st_mode=S_IFDIR|0755, st_size=4096, ...}) = 0
open("/usr/lib/mozilla/component.reg", O_RDWR) = -1 EACCES (Permission denied)
stat64("/usr/lib/mozilla/component.reg", {st_mode=S_IFREG|0644, st_size=382876,
...}) = 0
open("/usr/lib/mozilla/component.reg", O_RDONLY) = 3
fstat64(3, {st_mode=S_IFREG|0644, st_size=382876, ...}) = 0
mmap2(NULL, 382876, PROT_READ, MAP_PRIVATE, 3, 0) = 0x406cc000
_llseek(3, 0, [0], SEEK_SET)            = 0
munmap(0x406cc000, 382876)              = 0
close(3)                                = 0
--- SIGSEGV (Segmentation fault) ---
+++ killed by SIGSEGV +++


Version-Release number of selected component (if applicable):


How Reproducible:
Always

Steps to Reproduce:
1. install mozilla rpm
2. start mozilla
3. 

Actual Results:
SEGFAULT

Expected Results:


Additional Information:
Solved by
chmod 666 /usr/lib/mozilla/component.reg
Comment 1 Bill Crawford 2002-02-23 18:04:28 EST
Oops ... I somehow failed to see this before I logged #60256.
Anyway, it's actually caused by a glibc problem (see bug #60132).
Comment 2 Bill Crawford 2002-02-23 18:05:20 EST
*** Bug 60256 has been marked as a duplicate of this bug. ***
Comment 3 Bill Crawford 2002-03-08 20:15:09 EST
This was fixed for me by glibc-2.2.90-7, I guess the bug can be closed now.
Comment 4 Christopher Blizzard 2002-03-09 12:46:46 EST
OK.

Note You need to log in before you can comment on or make changes to this bug.