Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 602518 - Firefox has a segmentation violation when started on Fedora 13 MLS
Firefox has a segmentation violation when started on Fedora 13 MLS
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Gecko Maintainer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-09 23:15 EDT by Joe Nall
Modified: 2018-04-11 10:37 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-01-07 09:30:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screen shot of firefox segmentation violation (55.52 KB, image/png)
2010-06-09 23:15 EDT, Joe Nall
no flags Details

  None (edit)
Description Joe Nall 2010-06-09 23:15:49 EDT
Created attachment 422762 [details]
Screen shot of firefox segmentation violation

Description of problem:

Firefox segmentation violation

Version-Release number of selected component (if applicable):

firefox-3.6.3-4

How reproducible:

100%

Steps to Reproduce:

Configure Fedora as MLS/Enforcing
Start Firefox

http://www.nall.com/blog/?p=7
  
Actual results:

Firefox dies

Expected results:

Firefox starts.

Additional info:

I expect this is a bad policy interaction - but firefox should not segfault.
Comment 1 Daniel Walsh 2010-06-10 08:37:33 EDT
Do you have the allow_execmem boolean turned on?
Comment 2 Joe Nall 2010-06-10 10:21:00 EDT
That was it. Thanks Dan.
Comment 3 Matěj Cepl 2010-06-11 08:56:30 EDT
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

First of all, could we get output of the command

	rpm -qa \*xulrun\* \*firefox\* \*mozilla\* \*flash\* \*plugin\*

Please also install firefox-debuginfo (debuginfo-install is from
yum-utils package).

	debuginfo-install firefox

Then run firefox with a parameter -g. That will start firefox running inside of gdb debugger. Then use command run and do whatever you did to make firefox crash. When it happens, you should go back to the gdb and run

	(gdb) thread apply all backtrace

This produces usually many screens of the text. Copy all of them into a text editor and attach the file to the bug as an uncompressed attachment.

Please, install also valgrind (from valgrind package) and run

	valgrind --trace-children=yes --log-file=/tmp/firefox-valgrind-log.txt /usr/bin/firefox

(that's one line command, browser breaking this line into two notwithstanding)

Please, attach the file /tmp/firefox-valgrind-log.txt to this bug as an attachment as well.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 4 Chris Campbell 2011-01-07 08:06:22 EST
Reporter, I interpret Comment 2 to mean that this is not a bug. If this is true, please set this report closed NOTABUG. If there is still an issue, and this is a reproducible crash, please give us the steps to reproduce it for troubleshooting, thank you.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Note You need to log in before you can comment on or make changes to this bug.