Bug 60255 - NFS: giant filename in readdir (len 0x47a0c092)
NFS: giant filename in readdir (len 0x47a0c092)
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-02-22 18:49 EST by Terry Griffin
Modified: 2007-04-18 12:40 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-02-27 16:43:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Terry Griffin 2002-02-22 18:49:47 EST
Description of Problem:

The kernel gets in to a state where an NFS mounted directory appears to be empty when it's not,
and whenever I attempt to access this directory, a message of this form is logged:

     NFS: giant filename in readdir (len 0x47a0c092)

The NFS server is running HP-UX 10.20, NFSv2. Searching around on the web I found several
instances of this readdir() error that were associated with HP-UX NFS servers, indicating
a quirk in HP's NFSv2 implemenation.  However, something on the Linux client side is also
contributing because I was able to avoid the problem by upgrading to the 2.4.17 kernel from
kernel.org.

See entry 55864 which also involves readdir().

Version-Release number of selected component (if applicable):

2.4.9-21

How Reproducible:

Get yourself an HP-UX NFS server running NFSv2. Populate a directory
tree on that server. Mount that directory tree from Linux. Start accessing
files and directories from Linux and see if you get any readdir() errors
in /var/log/messages. With these messages you should observe that
certain files or directories appear to be missing.

Steps to Reproduce:
1. 
2. 
3. 

Actual Results:

NFS files fail to appear in directory listings.

Expected Results:

Files should be in the directory listings.

Additional Information:
Comment 1 Terry Griffin 2002-02-27 16:42:59 EST
I should have mentioned in the initial report that we also have some RH6.2 clients
mounting the same directories from the same HP-UX NFS server. They do not
have any issues with disappearing files on the NFS mounts.
Comment 2 Arjan van de Ven 2002-02-28 05:15:02 EST
2.4.17 has a workaround for the hp bug. The rawhide 2.4.17/2.4.18 kernels have
that too....

Note You need to log in before you can comment on or make changes to this bug.