Bug 60256 - seg fault while trying to read /usr/lib/mozilla/component.reg
seg fault while trying to read /usr/lib/mozilla/component.reg
Status: CLOSED DUPLICATE of bug 60245
Product: Red Hat Raw Hide
Classification: Retired
Component: mozilla (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Blizzard
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-02-22 20:23 EST by Bill Crawford
Modified: 2007-04-18 12:40 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-02-22 20:23:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Crawford 2002-02-22 20:23:10 EST
Description of Problem:
lstat64("/usr", {st_mode=S_IFDIR|0755, st_size=472, ...}) = 0
lstat64("/usr/lib", {st_mode=S_IFDIR|0755, st_size=92216, ...}) = 0
lstat64("/usr/lib/mozilla", {st_mode=S_IFDIR|0755, st_size=544, ...}) = 0
open("/usr/lib/mozilla/component.reg", O_RDWR) = -1 EACCES (Permission denied)
stat64("/usr/lib/mozilla/component.reg", {st_mode=S_IFREG|0644, st_size=472742,
...}) = 0
open("/usr/lib/mozilla/component.reg", O_RDONLY) = 3
fstat64(3, {st_mode=S_IFREG|0644, st_size=472742, ...}) = 0
mmap2(NULL, 472742, PROT_READ, MAP_PRIVATE, 3, 0) = 0x406ef000
_llseek(3, 0, [0], SEEK_SET)            = 0
munmap(0x406ef000, 472742)              = 0
close(3)                                = 0
--- SIGSEGV (Segmentation fault) ---
+++ killed by SIGSEGV +++

Version-Release number of selected component (if applicable):
[bill@pikachu bill]$ rpm -qa | egrep mozilla
mozilla-mail-0.9.8-2
mozilla-psm-0.9.8-2
mozilla-0.9.8-2
mozilla-js-debugger-0.9.8-2
kdebindings-kmozilla-3.0.0-0.cvs20020218.1
mozilla-devel-0.9.8-2
mozilla-chat-0.9.8-2
mozilla-dom-inspector-0.9.8-2

How Reproducible:
Try to run mozilla as non-root.

Additional information:
It works if I run mozilla as root.  This doesn't happen if
/usr/lib/mozilla/component.reg is made writable by the user.  The trace when run
as root looks like this:

...

lstat64("/usr", {st_mode=S_IFDIR|0755, st_size=472, ...}) = 0
lstat64("/usr/lib", {st_mode=S_IFDIR|0755, st_size=92216, ...}) = 0
lstat64("/usr/lib/mozilla", {st_mode=S_IFDIR|0755, st_size=544, ...}) = 0
open("/usr/lib/mozilla/component.reg", O_RDWR) = 3
fstat64(3, {st_mode=S_IFREG|0644, st_size=472742, ...}) = 0
mmap2(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) =
0x40017000
fstat64(3, {st_mode=S_IFREG|0644, st_size=472742, ...}) = 0
_llseek(3, 471040, [471040], SEEK_SET)  = 0
read(3, "ol;1?name=irc\0\0160\7\0\345/\7\0)\0\1\0B2\7\0\0\0"..., 1702) = 1702
_llseek(3, 0, [0], SEEK_SET)            = 0
read(3, "ADdv\1\0\2\0\2466\7\0\202\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0"..., 8192) =
8192
...
Comment 1 Bill Crawford 2002-02-23 18:05:25 EST

*** This bug has been marked as a duplicate of 60245 ***

Note You need to log in before you can comment on or make changes to this bug.