Bug 60259 - RFE: %ifdef() macro
RFE: %ifdef() macro
Status: CLOSED DEFERRED
Product: Red Hat Raw Hide
Classification: Retired
Component: rpm-build (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-02-22 20:58 EST by R P Herrold
Modified: 2007-04-18 12:40 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-23 11:40:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description R P Herrold 2002-02-22 20:58:16 EST
From rpm-list:

On Fri, Feb 22, 2002 at 12:48:19PM -0500, Serguei Ostrovskii wrote:
> Hello,
> I think it would be useful to have %ifdef operator.
> I sure can get away with things like
> %if %{?blah:1}%{!?blah:0}
> ... but that's not really pretty.
>
> Comments ?

Try
        %ifdef() %if %{expand:%%{?%{1}:1}%%{!?%{1}:0}}

If that "works", I might add to /usr/lib/rpm/macros, if desired.
Comment 1 R P Herrold 2005-02-23 11:40:04 EST
more than six months old - long since overtaken by events - closing; please
reopen if appropriate

Note You need to log in before you can comment on or make changes to this bug.