Bug 602684 - rhel6.1 @ base should have all the deps for subscription-manager cli installed
Summary: rhel6.1 @ base should have all the deps for subscription-manager cli installed
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager   
(Show other bugs)
Version: 6.1
Hardware: All Linux
low
medium
Target Milestone: rc
: ---
Assignee: Pradeep Kilambi
QA Contact: wes hayutin
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 568421
TreeView+ depends on / blocked
 
Reported: 2010-06-10 13:26 UTC by wes hayutin
Modified: 2010-06-11 12:13 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-11 12:13:18 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description wes hayutin 2010-06-10 13:26:56 UTC
This bug is to make sure @ base includes all the prereqs for subscription-manager when it drops in RHEL 6.1

Currently the deps are

[root@dell-pe1650-1 ~]# rpm -Uvh subscription-manager-*
error: Failed dependencies:
	PyXML is needed by subscription-manager-0.63-1.el6.i686
	python-simplejson is needed by subscription-manager-0.63-1.el6.i686
	gnome-python2 is needed by subscription-manager-gnome-0.63-1.el6.i686
	gnome-python2-canvas is needed by subscription-manager-gnome-0.63-1.el6.i686
	pygtk2 is needed by subscription-manager-gnome-0.63-1.el6.i686
	pygtk2-libglade is needed by subscription-manager-gnome-0.63-1.el6.i686
	usermode-gtk is needed by subscription-manager-gnome-0.63-1.el6.i686

Comment 1 Bill Nottingham 2010-06-10 16:33:38 UTC
@base is not intended to include GUI components.

Comment 2 wes hayutin 2010-06-10 17:45:15 UTC
heh.. good point.
I'll write up one more bug. This bug will only track the deps for subscription-manager-cli.

The cli requires the following two deps..
 PyXML is needed by subscription-manager-0.63-1.el6.i686
 python-simplejson is needed by subscription-manager-0.63-1.el6.i686

Comment 3 Bill Nottingham 2010-06-10 17:53:08 UTC
Note that if we just add subscription-manager to @base, dependencies will work. Those two packages are both in the main repo in current RHEL snapshots.

Comment 4 wes hayutin 2010-06-11 12:13:18 UTC
k.. understood. Thanks Bill.
closing this bug. We'll obviously cover this case when 6.1 drops


Note You need to log in before you can comment on or make changes to this bug.