Bugzilla will be upgraded to version 5.0 on December 2, 2018. The outage period for the upgrade will start at 0:00 UTC and have a duration of 12 hours
Bug 602688 - system-config-network removes GATEWAYDEV from /etc/sysconfig/network
system-config-network removes GATEWAYDEV from /etc/sysconfig/network
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: system-config-network (Show other bugs)
5.5
All Linux
medium Severity medium
: rc
: ---
Assigned To: Harald Hoyer
qe-baseos-daemons
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-10 09:37 EDT by Olivier Fourdan
Modified: 2018-10-27 09:39 EDT (History)
7 users (show)

See Also:
Fixed In Version: system-config-network-1.3.99.20-1.el5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-02-21 01:09:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Possible patch (759 bytes, patch)
2010-06-10 09:37 EDT, Olivier Fourdan
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2012:0231 normal SHIPPED_LIVE system-config-network bug fix and enhancement update 2012-02-20 10:07:45 EST

  None (edit)
Description Olivier Fourdan 2010-06-10 09:37:17 EDT
Created attachment 422907 [details]
Possible patch

Description of problem:

If GATEWAYDEV is set in /etc/sysconfig/network, running system-config-network will remove the option without notice.

Version-Release number of selected component (if applicable):

system-config-network-1.3.99.18-1.el5

How reproducible:

Always

Steps to Reproduce:

1. Add GATEWAYDEV=eth0 in /etc/sysconfig/network
2. Start system-config-network
3. Select File > Save
4. Check contents of /etc/sysconfig/network
  
Actual results:

GATEWAYDEV has been removed

Expected results:

GATEWAYDEV is left unchanged in /etc/sysconfig/network

Additional info:

This is from the fix for bug #78043, in netconfpkg/NCDeviceList.py:

  B<------B<------B<------B<------B<------B<------B<------B<------B<------
       [...]
       # bug #78043
       # we should have device specific gateways
       # fixed this way, until we have a way to mark the
       # default GATEWAY/GATEWAYDEV
       cfg = Conf.ConfShellVar(netconfpkg.ROOT + SYSCONFNETWORK)
       if cfg.has_key('GATEWAY'):
           del cfg['GATEWAY']
       if cfg.has_key('GATEWAYDEV'):
           del cfg['GATEWAYDEV']
       cfg.write()
  B<------B<------B<------B<------B<------B<------B<------B<------B<------

Removing the part that deletes gatewaydev fixes the issue.
Comment 2 RHEL Product and Program Management 2010-08-09 15:43:12 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 4 RHEL Product and Program Management 2011-05-31 11:26:07 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 8 errata-xmlrpc 2012-02-21 01:09:49 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0231.html

Note You need to log in before you can comment on or make changes to this bug.