Bug 602730 - Attempting to boot system with root on LVM snapshot yields - Unable to start dmeventd
Summary: Attempting to boot system with root on LVM snapshot yields - Unable to start ...
Status: CLOSED DUPLICATE of bug 589037
Alias: None
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
(Show other bugs)
Version: 13
Hardware: All Linux
low
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-06-10 15:16 UTC by James Laska
Modified: 2014-03-17 03:23 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-10 16:05:15 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
boot.log (17.00 KB, application/octet-stream)
2010-06-10 15:16 UTC, James Laska
no flags Details
/etc/rc.d/rc.sysinit (patch) (481 bytes, patch)
2010-06-10 15:17 UTC, James Laska
no flags Details | Diff

Description James Laska 2010-06-10 15:16:11 UTC
Created attachment 422946 [details]
boot.log

Description of problem:

While testing bug#602649 and trying to get LVM snapshot as a root volume working, I am getting error output from the 'lvm vgchange' initiated in /etc/rc.d/rc.sysinit.  

I'm not clear if this impacts the booted system or not.  A suggestion by harald@redhat.com is able to quiet the boot messages.

Version-Release number of selected component (if applicable):

 * initscripts-9.12-1.fc13.x86_64
 * lvm2-2.02.62-1.fc13.x86_64
 * device-mapper-event-1.02.45-1.fc13.x86_64


Steps to Reproduce:
1. Install Fedora 13 (leave enough free space in the LVM volume group to create a snapshot)

2. Create a snapshot of the root volume
  $ lvcreate -s -n lv_snap -L 9G /dev/vg_test1055/lv_root

3. Update /etc/grub.conf and /etc/fstab to boot the snapshot volume
  $ sed -i -e 's|lv_root|lv_swap|' /boot/grub/grub.conf
  $ sed -i -e 's|lv_root|lv_swap|' /etc/fstab
  
NOTE: the above will *only* change the "root=" value in grub.conf leaving the rd_LVM_LV values unchanged.
Actual results:

4. Reboot

Expected results:

A clean boot up that uses the LVM snapshot as the root volume

Additional info:

See attached boot.log for complete boot messages

		Welcome to Fedora 
		Press 'I' to enter interactive startup.
Starting udev: [  OK  ]
Setting hostname localhost:  [  OK  ]
Setting up Logical Volume Management: Child exited with code 5
  Unable to start dmeventd.
Child exited with code 5
  Unable to start dmeventd.
  vg_test1055-lv_snap: event registration failed: No such process
  vg_test1055/snapshot0: snapshot segment monitoring function failed.
Child exited with code 5
  Unable to start dmeventd.
Child exited with code 5
  Unable to start dmeventd.
  vg_test1055-lv_snap: event registration failed: No such process
  vg_test1055/snapshot0: snapshot segment monitoring function failed.
  3 logical volume(s) in volume group "vg_test1055" now active
[  OK  ]
Checking filesystems
Checking all file systems.
[/sbin/fsck.ext4 (1) -- /] fsck.ext4 -a /dev/mapper/vg_test1055-lv_root 
/dev/mapper/vg_test1055-lv_root: clean, 17749/578224 files, 207143/2310144 blocks
[/sbin/fsck.ext4 (1) -- /boot] fsck.ext4 -a /dev/sda1 
/dev/sda1: clean, 36/128016 files, 43255/512000 blocks
[  OK  ]
Remounting root filesystem in read-write mode:  [  OK  ]

Comment 1 James Laska 2010-06-10 15:17:22 UTC
Created attachment 422947 [details]
/etc/rc.d/rc.sysinit (patch)

The attached patch resolves the problem for me.  This was suggested by haraldh.  I'm not clear whether adding the --ignoremonitoring argument to the 'lvm vgchange' command would negatively impact other boot cases.

Comment 2 Bill Nottingham 2010-06-10 16:05:15 UTC

*** This bug has been marked as a duplicate of bug 589037 ***


Note You need to log in before you can comment on or make changes to this bug.