Bug 602829 - busy spinner cursor looks pixelated after circle boot
busy spinner cursor looks pixelated after circle boot
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: system-gnome-theme (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Ray Strode [halfline]
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-10 16:33 EDT by Dave Airlie
Modified: 2010-07-29 15:04 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-29 15:04:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
sample source PNG fed to xcursorgen (1.30 KB, image/png)
2010-07-12 03:45 EDT, Jakub Steiner
no flags Details

  None (edit)
Description Dave Airlie 2010-06-10 16:33:20 EDT
Description of problem:

At boot we do the cool spinner circle, then when gdm starts we pop up the spinner busy cursor. This cursor looks fairly pixely and not near as cool at startup and I'd expect after the cool ring.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 2 RHEL Product and Program Management 2010-06-10 17:03:20 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 3 Jakub Steiner 2010-07-12 03:41:00 EDT
I believe the 'pixeliness' is introduced to the cursors during the xcursorgen conversion -- it probably pre-multiplies alpha onto black. While you can't see it on the PNGs, it only seems to be happening on watch and left_ptr_watch cursors, which are generated by compositing the spinner animation onto a round base with imagemagick/graphicsmagic. Will investigate.
Comment 4 Jakub Steiner 2010-07-12 03:45:01 EDT
Created attachment 431099 [details]
sample source PNG fed to xcursorgen

Composited PNG doesn't seem to be jaggy, so it looks like xcursorgen is to blame.
Comment 7 Ray Strode [halfline] 2010-07-29 14:59:59 EDT
guess we missed the boat on this one.
Comment 8 RHEL Product and Program Management 2010-07-29 15:04:39 EDT
Development Management has reviewed and declined this request.  You may appeal
this decision by reopening this request.

Note You need to log in before you can comment on or make changes to this bug.