Bug 602879 - q4banking-devel multilib conflict
Summary: q4banking-devel multilib conflict
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: aqbanking
Version: 13
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-06-10 22:35 UTC by Philippe Troin
Modified: 2014-03-17 03:23 UTC (History)
3 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2010-08-03 00:39:12 UTC


Attachments (Terms of Use)

Description Philippe Troin 2010-06-10 22:35:48 UTC
Description of problem:

yum install q4banking-devel.{i686,x86_64}

yields:

Transaction Check Error:
  file /usr/include/q4banking/qbbankselector.ui.h from install of q4banking-devel-4.2.4-2.fc13.i686 conflicts with file from package q4banking-devel-4.2.4-2.fc13.x86_64
  file /usr/include/q4banking/qbcfgtab.ui.h from install of q4banking-devel-4.2.4-2.fc13.i686 conflicts with file from package q4banking-devel-4.2.4-2.fc13.x86_64
  file /usr/include/q4banking/qbcfgtabpageaccountgen.ui.h from install of q4banking-devel-4.2.4-2.fc13.i686 conflicts with file from package q4banking-devel-4.2.4-2.fc13.x86_64
  file /usr/include/q4banking/qbcfgtabpageaccounts.ui.h from install of q4banking-devel-4.2.4-2.fc13.i686 conflicts with file from package q4banking-devel-4.2.4-2.fc13.x86_64
  file /usr/include/q4banking/qbcfgtabpagebackends.ui.h from install of q4banking-devel-4.2.4-2.fc13.i686 conflicts with file from package q4banking-devel-4.2.4-2.fc13.x86_64
  file /usr/include/q4banking/qbcfgtabpageusergen.ui.h from install of q4banking-devel-4.2.4-2.fc13.i686 conflicts with file from package q4banking-devel-4.2.4-2.fc13.x86_64
  file /usr/include/q4banking/qbcfgtabpageusers.ui.h from install of q4banking-devel-4.2.4-2.fc13.i686 conflicts with file from package q4banking-devel-4.2.4-2.fc13.x86_64
  file /usr/include/q4banking/qbimporter.ui.h from install of q4banking-devel-4.2.4-2.fc13.i686 conflicts with file from package q4banking-devel-4.2.4-2.fc13.x86_64
  file /usr/include/q4banking/qbmapaccount.ui.h from install of q4banking-devel-4.2.4-2.fc13.i686 conflicts with file from package q4banking-devel-4.2.4-2.fc13.x86_64
  file /usr/include/q4banking/qbpickstartdate.ui.h from install of q4banking-devel-4.2.4-2.fc13.i686 conflicts with file from package q4banking-devel-4.2.4-2.fc13.x86_64
  file /usr/include/q4banking/qbprintdialog.ui.h from install of q4banking-devel-4.2.4-2.fc13.i686 conflicts with file from package q4banking-devel-4.2.4-2.fc13.x86_64
  file /usr/include/q4banking/qbprocesswatcher.ui.h from install of q4banking-devel-4.2.4-2.fc13.i686 conflicts with file from package q4banking-devel-4.2.4-2.fc13.x86_64
  file /usr/include/q4banking/qbselectbackend.ui.h from install of q4banking-devel-4.2.4-2.fc13.i686 conflicts with file from package q4banking-devel-4.2.4-2.fc13.x86_64
  file /usr/include/q4banking/qbselectbank.ui.h from install of q4banking-devel-4.2.4-2.fc13.i686 conflicts with file from package q4banking-devel-4.2.4-2.fc13.x86_64
  file /usr/include/q4banking/qbselectfromlist.ui.h from install of q4banking-devel-4.2.4-2.fc13.i686 conflicts with file from package q4banking-devel-4.2.4-2.fc13.x86_64
  file /usr/include/q4banking/qguiprogresswidget.ui.h from install of q4banking-devel-4.2.4-2.fc13.i686 conflicts with file from package q4banking-devel-4.2.4-2.fc13.x86_64
  file /usr/include/q4banking/qguisimplebox.ui.h from install of q4banking-devel-4.2.4-2.fc13.i686 conflicts with file from package q4banking-devel-4.2.4-2.fc13.x86_64


Version-Release number of selected component (if applicable):

q4banking-devel-4.2.4-2.fc13

Comment 1 Fedora Update System 2010-06-25 20:06:38 UTC
aqbanking-4.2.4-4.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/aqbanking-4.2.4-4.fc13

Comment 2 Bill Nottingham 2010-06-25 20:11:10 UTC
Thanks for the report. It's due to a 'feature' of uic, I've worked around it in -4. Rex is looking at a fix for uic so this workaround isn't needed in the future.

Comment 3 Fedora Update System 2010-06-28 17:08:41 UTC
aqbanking-4.2.4-4.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update aqbanking'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/aqbanking-4.2.4-4.fc13

Comment 4 Fedora Update System 2010-08-03 00:39:08 UTC
aqbanking-4.2.4-4.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.