Bug 60289 - makewhatis barfs when man page file names have parentheses or other magic characters in them
makewhatis barfs when man page file names have parentheses or other magic cha...
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: man (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: wdovlrrw
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-02-24 08:09 EST by Jonathan Kamens
Modified: 2007-04-18 12:40 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-02-24 08:09:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonathan Kamens 2002-02-24 08:09:37 EST
Output from makewhatis:

sh: -c: line 1: syntax error near unexpected token `./curses.h).'
sh: -c: line 1: `zcat ./curses.h).3x.pl1.gz'

This is because there are some broken man pages in the ncurses-devel package
with parentheses in their file names.  Still, makewhatis should not barf, given
this case.
Comment 1 Bernhard Rosenkraenzer 2002-02-26 09:26:23 EST
 Agreed, fixed in -5.

Note You need to log in before you can comment on or make changes to this bug.