Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 602904 - SIGESGV of vorbiscomment --tag
SIGESGV of vorbiscomment --tag
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: vorbis-tools (Show other bugs)
12
All Linux
low Severity medium
: ---
: ---
Assigned To: Kamil Dudka
Fedora Extras Quality Assurance
abrt_hash:c719b5968a5aaba6f7af576b363...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-10 20:46 EDT by Gideon Mayhak
Modified: 2010-08-02 20:37 EDT (History)
2 users (show)

See Also:
Fixed In Version: vorbis-tools-1.2.0-8.fc12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-07 13:48:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (3.69 KB, text/plain)
2010-06-10 20:46 EDT, Gideon Mayhak
no flags Details

  None (edit)
Description Gideon Mayhak 2010-06-10 20:46:07 EDT
abrt 1.0.9 detected a crash.

architecture: x86_64
Attached file: backtrace
cmdline: vorbiscomment --tag 'title=In The Mall' --write 09-in_the_mall.ogg
comment: It seems to only crash when using --tag and --write.  Using -t and -w didn't crash.
component: vorbis-tools
crash_function: __strlen_sse2
executable: /usr/bin/vorbiscomment
global_uuid: c719b5968a5aaba6f7af576b363b598a5f04e76c
kernel: 2.6.32.12-115.fc12.x86_64
package: vorbis-tools-1:1.2.0-6.fc12
rating: 4
reason: Process /usr/bin/vorbiscomment was killed by signal 11 (SIGSEGV)
release: Fedora release 12 (Constantine)

How to reproduce
-----
1. Take an Ogg Vorbis file that needs the title= field changed in its comments
2. Run vorbiscomment with --tag and --write
Comment 1 Gideon Mayhak 2010-06-10 20:46:09 EDT
Created attachment 423101 [details]
File: backtrace
Comment 2 Kamil Dudka 2010-06-15 04:54:59 EDT
Thanks for filing the bug!  I can reproduce the crash on Fedora 12:

$ gdb -q --args vorbiscomment --tag 'title=In The Mall' --write 09-in_the_mall.ogg
(gdb) r

Program received signal SIGSEGV, Segmentation fault.
__strlen_sse2 () at ../sysdeps/x86_64/strlen.S:31
31              pcmpeqb (%rdi), %xmm2
(gdb) bt
#0  __strlen_sse2 () at ../sysdeps/x86_64/strlen.S:31
#1  0x0000003177c7f006 in __strdup (s=0x0) at strdup.c:42
#2  0x0000000000404610 in parse_options (argc=5, argv=0x7fffffffe1d8, param=0x609030) at vcomment.c:521
#3  0x0000000000403b88 in main (argc=5, argv=0x7fffffffe1d8) at vcomment.c:176
(gdb) frame 2
#2  0x0000000000404610 in parse_options (argc=5, argv=0x7fffffffe1d8, param=0x609030) at vcomment.c:521
521                                     param->comments[param->commentcount++] = strdup(optarg);
(gdb) list
516                                     param->commentfilename = strdup(optarg);
517                                     break;
518                             case 't':
519                                     param->comments = realloc(param->comments, 
520                                                     (param->commentcount+1)*sizeof(char *));
521                                     param->comments[param->commentcount++] = strdup(optarg);
522                                     break;
523                             default:
524                                     usage();
525                                     exit(1);


The bug seems to be fixed in vorbis-tools-1.4.0-1.fc14.
Comment 3 Fedora Update System 2010-06-15 06:56:58 EDT
vorbis-tools-1.2.0-8.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/vorbis-tools-1.2.0-8.fc12
Comment 4 Fedora Update System 2010-06-15 06:57:03 EDT
vorbis-tools-1.2.0-8.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/vorbis-tools-1.2.0-8.fc13
Comment 5 Fedora Update System 2010-06-15 11:57:26 EDT
vorbis-tools-1.2.0-8.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update vorbis-tools'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/vorbis-tools-1.2.0-8.fc12
Comment 6 Fedora Update System 2010-06-15 12:05:58 EDT
vorbis-tools-1.2.0-8.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update vorbis-tools'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/vorbis-tools-1.2.0-8.fc13
Comment 7 Fedora Update System 2010-07-07 13:48:39 EDT
vorbis-tools-1.2.0-8.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 8 Fedora Update System 2010-08-02 20:37:48 EDT
vorbis-tools-1.2.0-8.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.