Bug 60293 - initscripts-6.53-1 is messing up $LANG
initscripts-6.53-1 is messing up $LANG
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: initscripts (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-02-24 14:56 EST by Jonathan Kamens
Modified: 2014-03-16 22:25 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-02-25 03:50:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonathan Kamens 2002-02-24 14:56:54 EST
I just upgraded to bash-2.05a-9.  I upgraded to glibc-2.2.90-7 at the same time,
but I don't think that's the guilty party.

After upgrading bash, it's messing up my LANG environment variable setting:

jik:~!7> echo $SHELL
/bin/tcsh
jik:~!8> echo $LANG
en_US
jik:~!9> bash -c 'echo $LANG'
en_US=
jik:~!10> 

This causes problems with programs that actually try to parse LANG, e.g.:

jik:~!10> bash -c 'perl -v'
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
        LANGUAGE = (unset),
        LC_ALL = (unset),
        LC_COLLATE = "C",
        LANG = "en_US="
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").

This is perl, v5.6.1 built for i386-linux-thread-multi

Copyright 1987-2001, Larry Wall

Perl may be copied only under the terms of either the Artistic License or the
GNU General Public License, which may be found in the Perl 5 source kit.

Complete documentation for Perl, including FAQ lists, should be found on
this system using `man perl' or `perldoc perl'.  If you have access to the
Internet, point your browser at http://www.perl.com/, the Perl Home Page.

jik:~!11>
Comment 1 Jonathan Kamens 2002-02-24 15:30:21 EST
Turns out this has nothing to do with bash.  The line "setenv LANG=$GDM_LANG" in
/etc/profile.d/lang.csh should say "setenv LANG $GDM_LANG".
Comment 2 Bill Nottingham 2002-03-28 17:15:41 EST
Yes, this was fixed in 6.54-1 and later.

Note You need to log in before you can comment on or make changes to this bug.