Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 602995 - [abrt] abrt-gui-1.1.5-1.el6: CCMainWindow.py:237:on_tvDumps_cursor_changed:UnicodeDecodeError: 'utf8' codec can't decode bytes in position 4-6: invalid data
[abrt] abrt-gui-1.1.5-1.el6: CCMainWindow.py:237:on_tvDumps_cursor_changed:Un...
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: abrt (Show other bugs)
6.0
x86_64 Linux
medium Severity high
: rc
: ---
Assigned To: Jiri Moskovcak
BaseOS QE - Apps
abrt_hash:46e20b90
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-11 04:25 EDT by Michal Nowak
Modified: 2015-02-01 17:52 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-14 10:10:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (874 bytes, text/plain)
2010-06-11 04:25 EDT, Michal Nowak
no flags Details

  None (edit)
Description Michal Nowak 2010-06-11 04:25:27 EDT
abrt version: 1.1.5
architecture: x86_64
cmdline: /usr/bin/python /usr/share/abrt/CCMainWindow.py
component: abrt
executable: /usr/share/abrt/CCMainWindow.py
kernel: 2.6.32-33.el6.x86_64
package: abrt-gui-1.1.5-1.el6
reason: CCMainWindow.py:237:on_tvDumps_cursor_changed:UnicodeDecodeError: 'utf8' codec can't decode bytes in position 4-6: invalid data
release: Red Hat Enterprise Linux release 6.0 Beta (Santiago)
time: 1276244509
uid: 500

backtrace
-----
CCMainWindow.py:237:on_tvDumps_cursor_changed:UnicodeDecodeError: 'utf8' codec can't decode bytes in position 4-6: invalid data

Traceback (most recent call last):
  File "/usr/share/abrt/CCMainWindow.py", line 237, in on_tvDumps_cursor_changed
    l_heading.set_markup(_("<b>%s Crash</b>\n%s") % (dump.getPackageName().title(),dump.getPackage()))
UnicodeDecodeError: 'utf8' codec can't decode bytes in position 4-6: invalid data

Local variables in innermost frame:
dump: <CCDump.Dump instance at 0x1b130e0>
self: <__main__.MainWindow instance at 0x1a49998>
path: [(0,)]
l_heading: <gtk.Label object at 0x1b15140 (GtkLabel at 0x1acde20)>
treeview: <gtk.TreeView object at 0x1a576e0 (GtkTreeView at 0x1af6120)>
i_package_icon: <gtk.Image object at 0x1b150f0 (GtkImage at 0x1ae50b0)>
dumpsListStore: <gtk.ListStore object at 0x1a57730 (GtkListStore at 0x17f6990)>
icon: None

comment
-----
I got this when I have clicked "Report".

/usr/share/abrt/CReporterAssistant.py:658: GtkWarning: Failed to set text from markup due to error parsing markup: Chyba na řádku 1, znak 20: V názvu je neplatný text v kódování UTF-8 - není platné "Bal��ek:"
  heading_lbl.set_markup("<b>%s:</b>" % heading)
/usr/share/abrt/CReporterAssistant.py:711: GtkWarning: Failed to set text from markup due to error parsing markup: Chyba na řádku 1, znak 24: V názvu je neplatný text v kódování UTF-8 - není platné "V�pis vol�n�"
  backtrace_lbl.set_markup(_("<b>Backtrace</b>"))
/usr/share/abrt/CReporterAssistant.py:777: GtkWarning: Failed to set text from markup due to error parsing markup: Chyba na řádku 1, znak 20: V názvu je neplatný text v kódování UTF-8 - není platné "Bal��ek:"
  page.pack_start(summary_scroll)
/usr/share/abrt/CReporterAssistant.py:777: GtkWarning: Failed to set text from markup due to error parsing markup: Chyba na řádku 1, znak 24: V názvu je neplatný text v kódování UTF-8 - není platné "V�pis vol�n�"
  page.pack_start(summary_scroll)


This happens for Slovak, French. But gu_IN is OK.

How to reproduce
-----
newman@dhcp-lab-222 abrt $ LANG=cs_CZ abrt-gui
/usr/share/abrt/CCMainWindow.py:65: GtkWarning: Invalid input string
  n = self.dlist.append_column(icon_column)
/usr/share/abrt/CCMainWindow.py:76: GtkWarning: Invalid input string
  n = self.dlist.append_column(column)
/usr/share/abrt/CCMainWindow.py:80: GtkWarning: Invalid input string
  column.set_resizable(True)
Traceback (most recent call last):
  File "/usr/share/abrt/CCMainWindow.py", line 237, in on_tvDumps_cursor_changed
    l_heading.set_markup(_("<b>%s Crash</b>\n%s") % (dump.getPackageName().title(),dump.getPackage()))
UnicodeDecodeError: 'utf8' codec can't decode bytes in position 4-6: invalid data
/usr/share/abrt/CCMainWindow.py:394: PangoWarning: Invalid UTF-8 string passed to pango_layout_set_text()
  self.window.show()
/usr/share/abrt/CCMainWindow.py:394: GtkWarning: Invalid input string
  self.window.show()
/usr/share/abrt/CCMainWindow.py:453: PangoWarning: Invalid UTF-8 string passed to pango_layout_set_text()
  gtk.main()
Comment 1 Michal Nowak 2010-06-11 04:25:30 EDT
Created attachment 423172 [details]
File: backtrace
Comment 3 RHEL Product and Program Management 2010-06-11 04:43:09 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 4 Jiri Moskovcak 2010-06-11 09:11:52 EDT
Do we support non utf locale? It works when running: LANG=cs_CZ.utf8 abrt-gui

J.
Comment 5 Michal Nowak 2010-06-11 09:20:35 EDT
Wondering which locale was chosen instead of UTF-8 and why UTF-8 is not the default one. However no idea whether we support non-utf locales... I briefly tested with that old GUI and no tracebacks were produced (however I saw no translation too...).
Comment 6 Jiri Moskovcak 2010-06-11 09:28:34 EDT
I tried some other gtk apps and they have problems with non-utf locale also.

J.

Note You need to log in before you can comment on or make changes to this bug.