Bug 603029 - cant delete/move/copy selected sheets
cant delete/move/copy selected sheets
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: openoffice.org (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Caolan McNamara
desktop-bugs@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-11 06:57 EDT by Tomas Pelka
Modified: 2010-06-11 07:48 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-11 07:39:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tomas Pelka 2010-06-11 06:57:22 EDT
Description of problem:
Not able to delete/move/copy sheets selected via Edit->Sheet->Select. Other options in mentioned menu Edit->Sheet are still greyed out (disabled).  

Version-Release number of selected component (if applicable):
openoffice.org-*-3.2.0-12.4.el6

How reproducible:
100%

Steps to Reproduce:
1.
2.
3.
  
Actual results:
Not able to delete/move/copy selected sheets.

Expected results:
We should be able to delete/move/copy selected sheets.

Additional info:
Comment 1 Caolan McNamara 2010-06-11 07:14:27 EDT
Works fine here, were you trying to delete *all* sheets ?, there has to be at least one left in a spreadsheet. Or was the document protected in some way ?. Maybe an exact step by step here
Comment 2 David Tardon 2010-06-11 07:17:49 EDT
dtardon->tpelka: you have change tracking enabled, right?
Comment 4 David Tardon 2010-06-11 07:21:28 EDT
dtardon->tpelka: you have change tracking enabled, right?
Comment 5 Tomas Pelka 2010-06-11 07:24:53 EDT
Hmm works fine in brand new spreadsheet without record enabled. When record is enabled than I'm not able to delete or move sheet. Is it a feature?
Comment 6 RHEL Product and Program Management 2010-06-11 07:33:23 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 7 David Tardon 2010-06-11 07:35:59 EDT
dtardon->tpelka: i have found it described neither in help nor in calc guide, but i suppose it is a feature, sort of... i.e. that the change tracking cannot handle sheet changes, so it disables them instead.
Comment 8 Tomas Pelka 2010-06-11 07:39:52 EDT
Yes seems reasonable. We can close this issue as not a bug.
Comment 9 David Tardon 2010-06-11 07:48:23 EDT
Eike Rathke, one of upstream calc developers, has confirmed in IRC communication it's disabled intentionally.

Note You need to log in before you can comment on or make changes to this bug.