Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 603140 - [abrt] crash in thunderbird-3.0.4-3.fc13: Process /usr/lib64/thunderbird-3.0/thunderbird-bin was killed by signal 11 (SIGSEGV)
[abrt] crash in thunderbird-3.0.4-3.fc13: Process /usr/lib64/thunderbird-3.0/...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: thunderbird (Show other bugs)
13
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Gecko Maintainer
Fedora Extras Quality Assurance
abrt_hash:bba2c77ca9370ddeeb08cb6061e...
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-11 12:25 EDT by Eric Blake
Modified: 2010-08-09 13:19 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-09 13:19:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (194.08 KB, text/plain)
2010-06-11 12:25 EDT, Eric Blake
no flags Details

  None (edit)
Description Eric Blake 2010-06-11 12:25:50 EDT
abrt 1.1.1 detected a crash.

architecture: x86_64
Attached file: backtrace
cmdline: /usr/lib64/thunderbird-3.0/thunderbird-bin
component: thunderbird
crash_function: nsProfileLock::FatalSignalHandler
executable: /usr/lib64/thunderbird-3.0/thunderbird-bin
global_uuid: bba2c77ca9370ddeeb08cb6061eece4863cadf80
kernel: 2.6.33.5-112.fc13.x86_64
package: thunderbird-3.0.4-3.fc13
rating: 4
reason: Process /usr/lib64/thunderbird-3.0/thunderbird-bin was killed by signal 11 (SIGSEGV)
release: Fedora release 13 (Goddard)
Comment 1 Eric Blake 2010-06-11 12:25:53 EDT
Created attachment 423330 [details]
File: backtrace
Comment 2 d. johnson 2010-08-09 10:14:43 EDT
Thank you for taking the time to report this bug. Updates to this package have been released since it was first reported. If you have time to update the package and re-test, please do so and report the results here. You can obtain the updated package by typing 'yum update <package>' or using the graphical updater, Software Update.

Disable any extensions, plugins and non-default themes.  Exit cleanly and restart thunderbird.  Are you able to replicate the crash?

Error while mapping shared library sections:
/home/remote/eblake/.thunderbird/pc053gnq.default/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/platform/Linux_x86_64-gcc3/components/libenigmime-x86_64-gcc3.so: Permission denied.
Core was generated by `/usr/lib64/thunderbird-3.0/thunderbird-bin'.


#2  <signal handler called>
No symbol table info available.
#3  nsCOMPtr_base::~nsCOMPtr_base (this=<value optimized out>, 
    __in_chrg=<value optimized out>) at nsCOMPtr.cpp:81
No locals.
#4  0x00007f91c561f2a3 in ~nsCOMPtr (this=0x7f91be6f6780, aEvent=
    0x7f91a3779ba0) at ../../../dist/include/xpcom/nsCOMPtr.h:469
No locals.
#5  nsJSEventListener::HandleEvent (this=0x7f91be6f6780, aEvent=
    0x7f91a3779ba0)
    at /usr/src/debug/thunderbird-3.0.4/comm-1.9.1/mozilla/dom/src/events/nsJSEventListener.cpp:293
        rv = 0
        iargv = {<nsCOMPtr_base> = {mRawPtr = 
    0x7f919c7ba1e0}, <No data fields>}
        eventString = {<nsFixedString> = {<nsString> = 
    {<nsAString_internal> = {mData = 0x7f919c7c5738, mLength = 15, mFlags = 
    65541}, <No data fields>}, mFixedCapacity = 63, mFixedBuf = 
    0x7fffbf1d1640}, mStorage = {99, 111, 109, 109, 97, 110, 100, 117, 112, 
    100, 97, 116, 101, 0, 92, 0, 55606, 52320, 32657, 0, 108, 0, 0, 0, 31120, 
    40083, 32657, 0, 13522, 40057, 32657, 0, 31120, 40083, 32657, 0, 12742, 
    62216, 58, 0, 31120, 40083, 32657, 0, 5824, 48925, 32767, 0, 30880, 
    40083, 32657, 0, 31120, 40083, 32657, 0, 55606, 52320, 32657, 0, 58839, 
    52320, 32657, 0}}
        atomName = {<nsCOMPtr_base> = {mRawPtr = 
    0x7f9100000001}, <No data fields>}
        funcval = {mObject = 0x7f91c28d6600, mContext = {<nsCOMPtr_base> = {
              mRawPtr = 0x7f91c3fc0d00}, <No data fields>}}
        handledScriptError = <value optimized out>
        vrv = {<nsCOMPtr_base> = {mRawPtr = 0x7f91a37d0060}, <No data fields>}
#6  0x00007f91c54fee98 in nsEventListenerManager::HandleEventSubType (this=
    0x7f91be6f8a20, aListenerStruct=0x7f91be6f8a60, aListener=0x7f91be6f6780, 
    aDOMEvent=0x7f91a3779ba0, aCurrentTarget=0x7f91bf395b50, 
    aPhaseFlags=<value optimized out>)
    at /usr/src/debug/thunderbird-3.0.4/comm-1.9.1/mozilla/content/events/src/nsEventListenerManager.cpp:1098
        result = <value optimized out>
#7  0x00007f91c54ff260 in nsEventListenerManager::HandleEvent (this=
    0x7f91be6f8a20, aPresContext=0x7f91c38f8c00, aEvent=0x7fffbf1d1d00, 
    aDOMEvent=0x7fffbf1d1bb0, aCurrentTarget=0x7f91bf395b50, aFlags=6, 
    aEventStatus=0x7fffbf1d1bb8)
    at /usr/src/debug/thunderbird-3.0.4/comm-1.9.1/mozilla/content/events/src/nsEventListenerManager.cpp:1206
        kungFuDeathGrip = {mRawPtr = 0x7f91be6f6780}
        ls = 0x7f91be6f8a60
        useTypeInterface = 0
        useGenericInterface = 1
        hasListener = 1
        pusher = {mScx = {<nsCOMPtr_base> = {mRawPtr = 
    0x7f91c3fc0d00}, <No data fields>}, mScriptIsRunning = 1}
        currentGroup = 0
        typeData = 0x7f91c5c77a90
        dispData = 0x7f91c57d38a8
        iter = 
    {<nsAutoTObserverArray<nsListenerStruct, 2u>::ForwardIterator> = 
    {<nsAutoTObserverArray<nsListenerStruct, 2u>::Iterator> = 
    {<nsTObserverArray_base::Iterator_base> = {mPosition = 1, mNext = 0x0}, 
              mArray = @0x7f91be6f8a48}, <No data fields>}, mEnd = 
    {<nsAutoTObserverArray<nsListenerStruct, 2u>::Iterator> = 
    {<nsTObserverArray_base::Iterator_base> = {mPosition = 1, mNext = 
    0x7fffbf1d19f0}, mArray = @0x7f91be6f8a48}, <No data fields>}}

You may need to correct permissions for the file above.




-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 3 Eric Blake 2010-08-09 10:31:16 EDT
So far, with thunderbird-3.1.1-1.fc13.x86_64, I haven't seen any crashes, and IMAP downloads feel like they are happening much faster.  If a crash does reoccur, I will be sure to report it though.

Meanwhile, /home/remote/eblake/.thunderbird/pc053gnq.default/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/platform/Linux_x86_64-gcc3/components/libenigmime-x86_64-gcc3.so is one of the files associated with a non-default extension.  Any reason that Fedora doesn't provide the enigmail add-on as a pre-packaged builtin (comparable to how it provides the thunderbird-lightning package), particularly since enigmail is rather picky about being compiled for the same architecture as thunderbird, and it is rather difficult to track down a pre-built 64-bit enigmail?
Comment 4 d. johnson 2010-08-09 12:38:45 EDT
Is it OK to close this bug with CURRENTRELEASE then?

Fedora does include that extension, "thunderbird-enigmail : Authentication and encryption extension for Mozilla Thunderbird" (via: rpmfusion-free due to license).




-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 5 Eric Blake 2010-08-09 12:47:11 EDT
Yes, closing this bug is okay with me.

rpmfusion-free (and therefore thunderbird-enigmail) is NOT part of Fedora.  However, thanks for pointing it out to me - it is indeed a way to get that add-on for use within Fedora.
Comment 6 d. johnson 2010-08-09 13:19:56 EDT
Thank you.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Note You need to log in before you can comment on or make changes to this bug.