Bug 603228 - I randomly loose all control of machine ...System freeze/infinite loop?
I randomly loose all control of machine ...System freeze/infinite loop?
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
13
i686 Linux
low Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-11 19:58 EDT by John Curcio
Modified: 2011-02-16 19:50 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-02-16 19:50:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Curcio 2010-06-11 19:58:03 EDT
Description of problem: At random times I seem to loose all control over my system. I cannot use the mouse or keyboard. I cannot go to a virtual terminal. My screen appears to freeze. The last time this happened, I was just beginning to play a song but when the machine appeared to freeze, it stopped for a second played the first second of the song, was silent for 2 or 3 seconds, and the would repeat ... it probably repeated for two minutes before I forced a shutdown. Typically I wait a few minutes and then force a shutdown although once the machine eventually (after 5 - 10 minutes) it did come back and I was able to regain control.

As you can tell I am not sure if this is a kernel issue, but that is my best guess.


Version-Release number of selected component (if applicable): 2.6.33.5-112.fc13.i686.PAE 


How reproducible: Seems completely random :-(


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info: Without being able to reproduce it at will it's difficult to know if/how you'll be able to debug this issue but I wanted to make you aware in case others are seeing the same thing or in case there is some information I can provide which may help. Thanks
Comment 1 charles harris 2010-06-11 23:37:50 EDT
My mouse and keyboard also freeze up, usually about 10-15 minutes after booting up, it happens quite reliably. The machine isn't dead by any means, the cpu fan roars to life, so it is busy doing something. But at that point my only option is to reboot into another system. This problem has been present since installation. Unlike this report, I am running the x86_64 version.
Comment 2 Ivan Razuvaev 2010-06-15 12:54:51 EDT
The same freezes. No unusual in /var/log/messages.
Comment 3 John Curcio 2010-06-17 05:59:21 EDT
Can I change the priority of this from low to high? ... I don't see how I can edit this and it was clearly an oversight to have it as a low priority. It's hard to get most anything done when your machine just ups and freezes on you .... sometimes a LOT.
Comment 4 John Curcio 2010-06-17 06:07:16 EDT
Upgraded to the latest and greatest kernel, 2.6.33.5-124.fc13.i686.PAE, but problem persists.

It is not deterministic but last night I seemed to have a LOT more freezes when I was running the MusicBranz Picard application.

While at times I'm seeing this problem show up a lot on my desktop, my little, el-cheap-o e-machine laptop is running F13 and has never had this problem.

I wondering what the others who are seeing the same problem are running for graphics cards. Are you all running relatively recent PCI-X Nvidia add-on graphics cards or something else? I believe mine is a 8600 (GTS?) ... have to double-check. On Fedora 12 I saw something similar to what I'm seeing now and the problem disappeared (entirely?) when I switched to an old ATI card. Not certain it's the same now but wanted to offer that info.
Comment 5 Ivan Razuvaev 2010-06-17 06:15:22 EDT
Every man who have this problem uses NVIDIA 7xxx or higher as i know. And the bug appers both with nouveau and nvidia drivers.
Comment 6 Ivan Razuvaev 2010-06-17 06:20:07 EDT
Some more info. As i know, chipsets where bug appeared are: 945P, 945GM, 965P, 965GM, P45, X48.
Comment 7 John Curcio 2010-06-18 08:56:39 EDT
That's good to know.

Does anyone else with this problem over-clocking their machine? I was just curious about that as it might be something else to try while we wait for a real bug fix.
Comment 8 Ivan Razuvaev 2010-06-18 09:09:59 EDT
No overclocking. Bug appears on default hardware parameters.
Comment 9 Ivan Razuvaev 2010-06-22 07:34:59 EDT
Try kernel option pcie_aspm=off. This fixes freezes for some people using
GF8600 video cards.
Comment 10 John Curcio 2010-06-28 18:38:26 EDT
I've been using this now for the last few days and have had no issues at all! Thanks very much for the help. The bug clearly still needs to be fixed but at least I can use my machine :-)

Note You need to log in before you can comment on or make changes to this bug.