Bug 603231 - systemd segfaults in libc right after booting
Summary: systemd segfaults in libc right after booting
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: systemd   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
low
high
Target Milestone: ---
Assignee: Lennart Poettering
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-06-12 00:09 UTC by John Paul Adrian Glaubitz
Modified: 2010-06-14 10:38 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-14 10:38:50 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Dump of systemd segfault upon booting (69.89 KB, text/plain)
2010-06-12 00:09 UTC, John Paul Adrian Glaubitz
no flags Details
Dump of systemd segfault upon booting (corrected) (285 bytes, application/octet-stream)
2010-06-12 00:11 UTC, John Paul Adrian Glaubitz
no flags Details
Output of 'systemd --test --running-as=init' (310.61 KB, application/octet-stream)
2010-06-12 00:12 UTC, John Paul Adrian Glaubitz
no flags Details
Dump of systemd segfault upon booting - 2nd reboot (285 bytes, application/octet-stream)
2010-06-12 00:23 UTC, John Paul Adrian Glaubitz
no flags Details
Dump of systemd segfault upon booting - 3rd reboot (285 bytes, application/octet-stream)
2010-06-12 00:23 UTC, John Paul Adrian Glaubitz
no flags Details
Dump of systemd segfault upon booting - 4th reboot (285 bytes, application/octet-stream)
2010-06-12 00:27 UTC, John Paul Adrian Glaubitz
no flags Details

Description John Paul Adrian Glaubitz 2010-06-12 00:09:03 UTC
Created attachment 423411 [details]
Dump of systemd segfault upon booting

Description of problem:

Today I tried 'systemd' for the first time on my Fedora Rawhide machine. I installed the package with yum and added 'init=/bin/systemd' to the kernel command line, then rebooted the machine. Upon rebooting the machine, a reproducible segfault in libc occurs upon which 'systemd' and therefore 'init' is killed, so that the kernel panics. I have rebooted the machine several times and found that the values for the CPU registers in the dump are the same most of the time, but differ sometimes. Please find the attached logs. I also ran '/bin/systemd --test --running-as=init' as suggested in #systemd on FreeNode and are attaching that output as well (stdout + stderr).

Version-Release number of selected component (if applicable):

systemd-0-0.3.20100610git2f198e.fc14.i686

How reproducible:

Always.

Steps to Reproduce:
1. Add 'init=/bin/systemd' to the kernel command line on a standard Fedora Rawhide
2. Reboot the machine
  
Actual results:

'systemd' segfaults

Expected results:

'systemd' runs the init scripts and the system comes up normally

Additional info:

uname -a
Linux oslo.physik.fu-berlin.de 2.6.34-20.fc14.i686 #1 SMP Wed Jun 2 13:12:51 UTC 2010 i686 i686 i386 GNU/Linux

Comment 1 John Paul Adrian Glaubitz 2010-06-12 00:11:05 UTC
Created attachment 423414 [details]
Dump of systemd segfault upon booting (corrected)

Please ignore the first dump attached, due to some weird bug in Google Chrome, a different file for upload was chosen than I actually selected.

Comment 2 John Paul Adrian Glaubitz 2010-06-12 00:12:32 UTC
Created attachment 423415 [details]
Output of 'systemd --test --running-as=init'

Comment 3 John Paul Adrian Glaubitz 2010-06-12 00:23:13 UTC
Created attachment 423417 [details]
Dump of systemd segfault upon booting - 2nd reboot

Comment 4 John Paul Adrian Glaubitz 2010-06-12 00:23:45 UTC
Created attachment 423418 [details]
Dump of systemd segfault upon booting - 3rd reboot

Comment 5 John Paul Adrian Glaubitz 2010-06-12 00:27:25 UTC
Created attachment 423419 [details]
Dump of systemd segfault upon booting - 4th reboot

Comment 6 Rahul Sundaram 2010-06-14 10:38:50 UTC
I have pushed another build which should resolve this issue.


Note You need to log in before you can comment on or make changes to this bug.