Bug 60327 - XFree with Xinerama misscalculates DPI
XFree with Xinerama misscalculates DPI
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.2
athlon Linux
medium Severity low
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-02-25 11:35 EST by Heinz Deinhart
Modified: 2007-04-18 12:40 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-02-26 01:48:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Heinz Deinhart 2002-02-25 11:35:40 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.0.3 (X11; Linux i686; U;) Gecko/20020205

Description of problem:
XFree86 fails to calculate DPI correctly when using Xinerama

example: two monitors, each has 1600x1200 resolution and each of them is
372x271mm big.
e.g. xdpyinfo shows:
[..]
screen #0:
 dimensions: 3200x1200 pixels (372x271 millimeters)
 resolution: 245x131 dots per inch
[..]

IMHO that means when calculating the "dots per inch" it uses the total
resolution but only the size of the first monitor.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. config X to use xinerama with 2 monitors (horizontally)
2. start X
3. launch xdpyinfo to see it
	

Actual Results:  DPI are set incorrect.

Many apps look really ugly, because the true type fonts are rendered much too
big, e.g. surfing on redhat.com with mozilla or galeon is really a pain..

Expected Results:  It should calc it correctly, as it does when running with
only one monitor. Probably the best solution would be to use only 1 monitor when
calculating the DPI of the display.

Additional info:

Workarounds:

a) using -dpi as X server option does not work very good, because somehow X
seems two change the value even if u specify it (but it is slightly better than
before)

b) use DisplaySize to specify some dimension of the first monitor, so that the
wrong calculations lead to correct DPI settings - works, but is not very nice
Comment 1 Mike A. Harris 2002-05-21 01:42:36 EDT
This problem should be reported directly to XFree86.org upstream via
the xpert@xfree86.org mailing list, and the xfree86@xfree86.org bug
report address.  We provide Xinerama as a convenience, however we do
not officially provide support for it.  When possible, when we can
track down an upstream bug fix for such an issue, they are generally
applied to our future erratum however.

Note You need to log in before you can comment on or make changes to this bug.