Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 603271 - install-guide section incomplete (3.2.2.2.1. Making Fedora USB Media with livecd-tools)
install-guide section incomplete (3.2.2.2.1. Making Fedora USB Media with liv...
Status: CLOSED CURRENTRELEASE
Product: Fedora Documentation
Classification: Fedora
Component: install-guide (Show other bugs)
devel
All Linux
low Severity medium
: ---
: ---
Assigned To: Petr Bokoc
Ruediger Landmann
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-12 02:16 EDT by Ed
Modified: 2013-07-29 11:45 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-29 11:45:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ed 2010-06-12 02:16:29 EDT
Description of problem:

Information is not complete enough for new-to-Fedora user to follow without problems/confusion.

- Page does not make it clear whether drive itself (/dev/sdb for me under Ubuntu 10.04) or partition (/dev/sdb1 for me) is to be specified on the command-line with livecd-iso-to-disk. The example mentions /dev/sdc1, but I ran into problems (below) with that. Also, the example begins with "You have a USB flash drive plugged into your computer, named /dev/sdc1" - this is not correct, AFAIK - as per old-style device naming conventions, the device itself should be /dev/sdc, and /dev/sdc1 should be a partition on that device.

- Documentation does not mention requirement for vfat partition on thumb drive (see session transcript below) and minimum size of the partition (and approximate free space required). Ideally, this should be added, since will be known for each release.

How reproducible:

Visit http://docs.fedoraproject.org/en-US/Fedora/13/html/Installation_Guide/Making_USB_Media-UNIX_Linux-other.html and try to follow procedure with F13 i686 Live CD ISO (d/l from http://fedoramirror.hnsdc.com/releases/13/Live/i686/Fedora-13-i686-Live.iso) with 1 GB USB thumb drive with data on it (bootable Ubuntu 10.04, created using Ubuntu's "USB Startup Disk" utility).

Additional info:

Running Ubuntu 10.04 (installed on local HDD) and trying to follow the documentation to create a Fedora bootable USB drive from which I can install Fedora on another system.

Session transcript (with common info snipped):

root@edgar-laptop:~# /tmp/mnt/LiveOS/livecd-iso-to-disk /new-storage/downloads/Fedora-13-i686-Live.iso /dev/sdb1
Verifying image...
/tmp/mnt/LiveOS/livecd-iso-to-disk: line 399: checkisomd5: command not found
Are you SURE you want to continue?
Press Enter to continue or ctrl-c to abort

Unable to fit live image + overlay on available space on USB stick
+ Size of live image:  660
---------------------------
= Requested:  660
- Available:  0
---------------------------
= To fit, free or decrease requested size total by:  660
Cleaning up to exit...
root@edgar-laptop:~# mkfs.ext3 /dev/sdb1
mke2fs 1.41.11 (14-Mar-2010)
Filesystem label=
OS type: Linux
[snip]
This filesystem will be automatically checked every 36 mounts or
180 days, whichever comes first.  Use tune2fs -c or -i to override.
root@edgar-laptop:~# sync
root@edgar-laptop:~# /tmp/mnt/LiveOS/livecd-iso-to-disk /new-storage/downloads/Fedora-13-i686-Live.iso /dev/sdb1
Verifying image...
/tmp/mnt/LiveOS/livecd-iso-to-disk: line 399: checkisomd5: command not found
Are you SURE you want to continue?
Press Enter to continue or ctrl-c to abort

USB filesystem must be vfat or ext[23]
Cleaning up to exit...
root@edgar-laptop:~# mkfs.vfat /dev/sdb1 
mkfs.vfat 3.0.7 (24 Dec 2009)

root@edgar-laptop:~# /tmp/mnt/LiveOS/livecd-iso-to-disk /new-storage/downloads/Fedora-13-i686-Live.iso /dev/sdb1
Verifying image...
/tmp/mnt/LiveOS/livecd-iso-to-disk: line 399: checkisomd5: command not found
Are you SURE you want to continue?
Press Enter to continue or ctrl-c to abort

Copying live image to USB stick
Updating boot config file
Installing boot loader
Comment 1 Ed 2010-06-12 02:53:45 EDT
Submitted new bug https://bugzilla.redhat.com/show_bug.cgi?id=603277 regarding confusing message from/behavior of livecd-iso-to-disk w.r.t. ext3 partition v/s vfat partition.
Comment 2 Karsten Wade 2011-12-13 22:49:08 EST
Removing myself for these bug components as I'm either no longer involved in that aspect of the project, or no longer care to watch this particular bug. Sorry if you are caught in a maelstrom of bug changes as a result!
Comment 3 Jack Reed 2012-11-12 23:39:11 EST
Hi Ed,

Sorry it's taken so long to address this bug. I'll go through what I've done point-by-point.

(In reply to comment #0)
> - Page does not make it clear whether drive itself (/dev/sdb for me under
> Ubuntu 10.04) or partition (/dev/sdb1 for me) is to be specified on the
> command-line with livecd-iso-to-disk. The example mentions /dev/sdc1, but I
> ran into problems (below) with that. Also, the example begins with "You have
> a USB flash drive plugged into your computer, named /dev/sdc1" - this is not
> correct, AFAIK - as per old-style device naming conventions, the device
> itself should be /dev/sdc, and /dev/sdc1 should be a partition on that
> device.

Yes, the distinction between device and partition was unclear here. In Example 3.1, I've changed

"You have a USB flash drive plugged into your computer, named /dev/sdc1"

to

"You have a USB flash drive plugged into your computer, named /dev/sdc, with a partition named /dev/sdc1"

and the final step of the example is now:

"Run livecd-iso-to-disk to transfer the live image to the partition on your flash drive and make the flash drive bootable"

 
> - Documentation does not mention requirement for vfat partition on thumb
> drive (see session transcript below) and minimum size of the partition (and
> approximate free space required). Ideally, this should be added, since will
> be known for each release.

Regarding the vfat partition, bug 603277 (which you referenced in Comment 1) concluded that this was an Ubuntu problem, so I won't update the guide with this requirement.

Regarding required space, I've added an admonition to the start of section 3.2, to cover all the USB media procedures, that states the following:

"Your USB media will need free space equal to the size of the ISO you obtained in Chapter 2, Obtaining Fedora. For example, a 2.2GB DVD ISO will need 2.2GB of free space on the USB drive, but having slightly more free space is ideal."

You can view the changes in the commit at http://git.fedorahosted.org/cgit/docs/install-guide.git/commit/?id=264eb0baea90d7bc47df3dcfe78fbe80eac9ab3f

Note You need to log in before you can comment on or make changes to this bug.