Bug 60334 - Segfault building php 4.1.1
Segfault building php 4.1.1
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: gcc (Show other bugs)
7.2
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-02-25 17:16 EST by asasas
Modified: 2007-04-18 12:40 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-02-25 17:16:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description asasas 2002-02-25 17:16:10 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; Q312461)

Description of problem:
Tyan Thunder S2510 Dual PIII 1GHz / 2G ECC Registered RAM / Dual NICs

This has been driving me nuts, and so I finally tore down the entire system, 
and did a clean install of Redhat 7.2 + a RHN up2date pass. 

I normally build apache+php a couple of times a day, and have a custom 
framework that scripts much of the build process. This has worked fine for 
months under RedHat 7.2. In the last month or so, I see segfaults both in the 
automatic build process as well as very basic manual build attempt. 

I did a clean install, but still see the segfaults.

To reproduce:
I ./configure apache

then in php-4.1.1/ I do 
./configure --with-apache=../apache_1.3.23
then make
then I get the following:

p-4.1.1/Zend -I/root/php-4.1.1/ext/mysql/libmysql -I/root/php-
4.1.1/ext/xml/expat  -I/root/php-4.1.1/TSRM -g -O2  -c dns.c && touch dns.lo
gcc -I. -I/root/php-4.1.1/ext/standard -I/root/php-4.1.1/main -I/root/php-
4.1.1 -I/root/apache_1.3.23/src/include -I/root/apache_1.3.23/src/os/unix -
I/root/php-4.1.1/Zend -I/root/php-4.1.1/ext/mysql/libmysql -I/root/php-
4.1.1/ext/xml/expat  -I/root/php-4.1.1/TSRM -g -O2  -c exec.c && touch exec.lo
gcc -I. -I/root/php-4.1.1/ext/standard -I/root/php-4.1.1/main -I/root/php-
4.1.1 -I/root/apache_1.3.23/src/include -I/root/apache_1.3.23/src/os/unix -
I/root/php-4.1.1/Zend -I/root/php-4.1.1/ext/mysql/libmysql -I/root/php-
4.1.1/ext/xml/expat  -I/root/php-4.1.1/TSRM -g -O2  -c file.c && touch file.lo
file.c: In function `zif_socket_set_blocking':
file.c:872: Internal error: Segmentation fault.
Please submit a full bug report.
See <URL:http://bugzilla.redhat.com/bugzilla/> for instructions.
make[3]: *** [file.lo] Error 1
make[3]: Leaving directory `/root/php-4.1.1/ext/standard'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/root/php-4.1.1/ext/standard'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/root/php-4.1.1/ext'
make: *** [all-recursive] Error 1

This is not a consistent error. I can make clean, ./configure, make again at 
times and it will run through, or segfault in a different location. Maybe 50% 
of the time it segfaults, though the variability in that is probably pretty 
large.

Here's another sample segfault:
oot/php-4.1.1/Zend -I/root/php-4.1.1/ext/mysql/libmysql -I/root/php-
4.1.1/ext/xml/expat  -I/root/php-4.1.1/TSRM -g -O2  -c charset.c && touch 
charset.lo
gcc -I. -I/root/php-4.1.1/ext/mysql/libmysql -I/root/php-4.1.1/main -I/root/php-
4.1.1 -I/root/apache_1.3.23/src/include -I/root/apache_1.3.23/src/os/unix -
I/root/php-4.1.1/Zend -I/root/php-4.1.1/ext/mysql/libmysql -I/root/php-
4.1.1/ext/xml/expat  -I/root/php-4.1.1/TSRM -g -O2  -c ctype.c && touch ctype.lo
In file included from global.h:141,
                 from ctype.c:4:
/usr/include/stdio.h:266: Internal error: Segmentation fault.
Please submit a full bug report.
See <URL:http://bugzilla.redhat.com/bugzilla/> for instructions.
make[4]: *** [ctype.lo] Error 1
make[4]: Leaving directory `/root/php-4.1.1/ext/mysql/libmysql'
make[3]: *** [all-recursive] Error 1
make[3]: Leaving directory `/root/php-4.1.1/ext/mysql/libmysql'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/root/php-4.1.1/ext/mysql'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/root/php-4.1.1/ext'
make: *** [all-recursive] Error 1

I'm at a loss as to what could cause this. Two options it seems to me are a 
hardware problem, though this is a server board with ECC RAM, so it seems that 
is unlikely, or a glitch introduced with an update from RHN. Since this problem 
is holding up significant work would be happy to spend time trying out options 
or giving shell access if that would help things.

How reproducible:
Sometimes
Comment 1 Jakub Jelinek 2002-02-26 18:04:37 EST
If it is a random failure, I would:
a) check carefully RAM and the rest of your hardware
b) on athlon, try either kernel noathlon option or install an i686 kernel
   (some athlon bioses are buggy)
Comment 2 asasas 2002-02-28 00:06:41 EST
The kernel was probably i686 if that's what Redhat 7.2 normally installs. 
Memory is Registered ECC so it'd be suprising if it had gone bad. 

Downloaded the latest pensacola release and so far 5 compiles havn't bombed 
out.

Note You need to log in before you can comment on or make changes to this bug.