Bug 60343 - PJL commands on printer output with HP Laserjet Series II
Summary: PJL commands on printer output with HP Laserjet Series II
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: foomatic (Show other bugs)
(Show other bugs)
Version: 7.2
Hardware: i386 Linux
high
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact:
URL: http://www.linuxprinting.org/newsport...
Whiteboard:
Keywords:
: 61583 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-02-26 04:32 UTC by Fred Brooks
Modified: 2008-05-01 15:38 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-18 10:51:16 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/etc/alchemist/namespace/printconf/local.adl (418 bytes, application/octet-stream)
2002-02-26 15:19 UTC, Fred Brooks
no flags Details

Description Fred Brooks 2002-02-26 04:32:16 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows 98; T312461; Q312461)

Description of problem:
When printing, a extra page is output with a header of.
@PJL JOB NAME="LPDOMATIC"
printer output was fine under RH 7.1  have updated to latest
foomatic and printconf RPMS.  

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.print anything
2.
3.
	

Additional info:

Comment 1 Tim Waugh 2002-02-26 08:49:36 UTC
Please explicitly list the version numbers of foomatic and printconf that you
have installed.

Also please attach /etc/alchemist/namespace/printconf/local.adl.

What kind of printer is this?

Comment 2 Fred Brooks 2002-02-26 15:19:22 UTC
Created attachment 46681 [details]
/etc/alchemist/namespace/printconf/local.adl

Comment 3 Fred Brooks 2002-02-26 15:23:41 UTC
foomatic-1.1-0.20011218.3
printconf-0.3.61-3

The printer is a HP Laserjet series II

Here my temp fix for the problem.
__________________________________
> How did you fix the PJL problem. I see you said your removed the
> language (but how?).

Another guy on the list said that the root of this problem is a problem
with RedHat.  Apparently they screwed up the PJL in their distribution. 
Now, I didn't go and fix that, he may be correct.

The way that I removed the language was to edit the file:

/usr/share/foomatic/db/source/printer/110624.xml

And remove the line that said <PJL/>.  Then I deleted all of the files
called '110624' in this directory:

/var/cache/foomatic/

And I reinstalled the printer.

Now I don't know what effects that will have on my printing, but I
haven't noticed any so far...

		Have fun,
			Ted

Comment 4 Tim Waugh 2002-03-04 18:39:30 UTC
Do you just get '@PJL JOB NAME="LPDOMATIC"', or is there any more than that?

Comment 5 Need Real Name 2002-03-04 19:24:14 UTC
I have a Laserjet Series II printer attached to my Linux box. It works
fine when the Mrs. Prints from her windows box. When I print from the
Linux box I get the following 'banner?' page printed before it prints
the requested page/s.

@PJL RESET
          @PJL EOJ
                  @PJL JOB NAME="LPDOMATIC"

Comment 6 Tim Waugh 2002-03-05 12:30:25 UTC
Could someone please try the foomatic package from rawhide and let me know:
a) the version-release that you tried, and
b) whether it fixed this problem or not

Thanks.

Comment 7 Tim Waugh 2002-03-05 12:50:39 UTC
Oh, wait, before doing that, could someone please try this small change?:

In /usr/sbin/lpdomatic, please change line 773 from:

     if ( @pjlprepend > 0) {

to

     if ( @pjlprepend > 1) {

and make the same change at line 779.  So it should look like:

            if ( @pjlprepend > 1 ) {
                print $fileh @pjlprepend;
            }
            while (<KID4_IN>) {
                print $fileh $_;
            }
            if ( @pjlprepend > 1 ) {
                print $fileh @pjlappend;
            }


Let me know if that fixes the problem.

Comment 8 Need Real Name 2002-03-05 13:22:25 UTC
making this change

In /usr/sbin/lpdomatic, please change line 773 from:

     if ( @pjlprepend > 0) {

to

     if ( @pjlprepend > 1) {

and make the same change at line 779.  So it should look like:

            if ( @pjlprepend > 1 ) {
                print $fileh @pjlprepend;
            }
            while (<KID4_IN>) {
                print $fileh $_;
            }
            if ( @pjlprepend > 1 ) {
                print $fileh @pjlappend;
            }

Appears to work. I was able to print without the bonus page.



Comment 9 Tim Waugh 2002-04-04 12:38:04 UTC
This has been fixed in rawhide for a while now.

Comment 10 Tim Waugh 2002-04-04 14:44:09 UTC
*** Bug 61583 has been marked as a duplicate of this bug. ***

Comment 11 Tim Waugh 2002-05-17 07:28:44 UTC
*** Bug 65088 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.