Bug 603475 - Mouse scroll doesn't work in Gimp when tablet is configured
Mouse scroll doesn't work in Gimp when tablet is configured
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-wacom (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Peter Hutterer
Fedora Extras Quality Assurance
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-13 08:01 EDT by Airbete
Modified: 2018-04-11 10:38 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-06-27 14:07:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xorg.conf (421 bytes, text/plain)
2010-06-14 08:27 EDT, Airbete
no flags Details
Xorg.0.log (20.68 KB, text/plain)
2010-06-14 08:28 EDT, Airbete
no flags Details
dmesg (52.04 KB, text/plain)
2010-06-14 08:28 EDT, Airbete
no flags Details
messages (64.86 KB, text/plain)
2010-06-14 08:28 EDT, Airbete
no flags Details

  None (edit)
Description Airbete 2010-06-13 08:01:23 EDT
Description of problem:
I've got my Wacom tablet configured in Gimp (screen mode). Prior to version 0.10.6-3 it worked flawlessly. Upgrading to 0.10.6-3 makes my _mouse_ not functionning correctly (in gimp): the buttons are deactivated and so is the scroll. If i explicitly add the mouse in gimp device menu i can get the buttons to work again but not the scroll. I didn't have this problem with 0.10.6-1 and i reverted to this version (and everything works fine).

Version-Release number of selected component (if applicable): 0.10.6-3

How reproducible: Always

Steps to Reproduce:
1. Start Gimp
2. Configure the use of the tablet (if it's not already done)
3. Try using your mouse (esp. button+scroll).
  
AB.
Comment 1 Matěj Cepl 2010-06-14 06:16:58 EDT
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

Please, check that your system configuration is correct in the new world order of Xorg-server 1.8 (https://fedoraproject.org/wiki/Input_device_configuration). If a configuration changes help to make your tablet work, please, attach them here, so we can fix our packages.

Otherwise, please add drm.debug=0x04 to the kernel command line, restart computer, and attach

* your X server config file (/etc/X11/xorg.conf, if available),
* X server log file (/var/log/Xorg.*.log),
* output of the xev command when tablet doesn't work as it should,
* output of the dmesg command, and
* system log (/var/log/messages)

to the bug report as individual uncompressed file attachments using the bugzilla file attachment link above.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 2 Airbete 2010-06-14 08:26:46 EDT
I have attached the requested files.

Regarding
* output of the xev command when tablet doesn't work as it should,

Tablet does work correctly. It's mouse scrolling that stops working but only in Gimp and only when tablet is enabled (in the extended device panel of Gimp). Scrolling stopped working when i upgraded from 0.10.6-1 to 0.10.6-3. It still doesn't work with 0.10.6-4.

AB.
Comment 3 Airbete 2010-06-14 08:27:34 EDT
Created attachment 423810 [details]
xorg.conf
Comment 4 Airbete 2010-06-14 08:28:04 EDT
Created attachment 423811 [details]
Xorg.0.log
Comment 5 Airbete 2010-06-14 08:28:36 EDT
Created attachment 423812 [details]
dmesg
Comment 6 Airbete 2010-06-14 08:28:52 EDT
Created attachment 423813 [details]
messages
Comment 8 Bug Zapper 2011-06-02 07:04:11 EDT
This message is a reminder that Fedora 13 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 13.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '13'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 13's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 13 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 9 Bug Zapper 2011-06-27 14:07:09 EDT
Fedora 13 changed to end-of-life (EOL) status on 2011-06-25. Fedora 13 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.