Bug 603569 - Segfault in swrast.c:get_window_size() (vboxvideo)
Segfault in swrast.c:get_window_size() (vboxvideo)
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: desktop-effects (Show other bugs)
13
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Owen Taylor
Fedora Extras Quality Assurance
abrt_hash:99ccd3e2406afd0acd4a03b5a74...
:
: 587542 605855 607889 608551 611821 614349 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-13 18:04 EDT by Noel Duffy
Modified: 2010-07-14 12:42 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-23 11:57:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (9.81 KB, text/plain)
2010-06-13 18:04 EDT, Noel Duffy
no flags Details

  None (edit)
Description Noel Duffy 2010-06-13 18:04:44 EDT
abrt 1.1.1 detected a crash.

architecture: x86_64
Attached file: backtrace
cmdline: desktop-effects
comment: Crashes always during startup. I am running Fedora 13 (Goddard) under Virtualbox 3.2.4 (r62467).
component: desktop-effects
crash_function: get_window_size
executable: /usr/bin/desktop-effects
global_uuid: 99ccd3e2406afd0acd4a03b5a747b37178f6ee81
kernel: 2.6.33.5-112.fc13.x86_64
package: desktop-effects-0.8.6-1.fc13
rating: 4
reason: Process /usr/bin/desktop-effects was killed by signal 11 (SIGSEGV)
release: Fedora release 13 (Goddard)

How to reproduce
-----
1. Run Fedora 13 in Virtualbox on Win7
2. Click System, Preferences, Desktop Effects.
3. Crash in startup.
Comment 1 Noel Duffy 2010-06-13 18:04:45 EDT
Created attachment 423698 [details]
File: backtrace
Comment 2 Owen Taylor 2010-06-22 22:11:47 EDT
*** Bug 605855 has been marked as a duplicate of this bug. ***
Comment 3 Owen Taylor 2010-06-23 11:51:47 EDT
*** Bug 587542 has been marked as a duplicate of this bug. ***
Comment 4 Owen Taylor 2010-06-23 11:57:40 EDT
This crash is occurring only with the VirtualBox 3D drivers, which are not part of the Fedora distribution, and seems to reflect a bug in those drivers. It should be reported to VirtualBox/Sun/Oracle. If someone does that, including a reference to the bug report in a comment here would be appreciated.
Comment 5 Noel Duffy 2010-06-26 02:17:32 EDT
I posted a ticket at virtualbox.org regarding this issue.

http://www.virtualbox.org/ticket/7061

I am now waiting to see if there is a response. I also posted to the VirtualBox forum but so far only one other person has reported a similar issue.
Comment 6 Owen Taylor 2010-06-28 14:18:15 EDT
*** Bug 607889 has been marked as a duplicate of this bug. ***
Comment 7 Owen Taylor 2010-06-28 14:18:22 EDT
*** Bug 608551 has been marked as a duplicate of this bug. ***
Comment 8 Owen Taylor 2010-07-06 12:12:39 EDT
*** Bug 611821 has been marked as a duplicate of this bug. ***
Comment 9 Owen Taylor 2010-07-14 12:42:17 EDT
*** Bug 614349 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.