Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 603603 - chkconfig fails to create K?? symlinks
chkconfig fails to create K?? symlinks
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: chkconfig (Show other bugs)
5.5.z
All Linux
low Severity medium
: rc
: ---
Assigned To: Bill Nottingham
qe-baseos-daemons
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-14 00:35 EDT by David Hartmann
Modified: 2014-03-16 23:23 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-10 15:14:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Hartmann 2010-06-14 00:35:43 EDT
Description of problem:

The chkconfig utility fails to create kill script sym links and only creates start script symlinks.

Version-Release number of selected component (if applicable):

chkconfig-1.3.30.2-2.el5

How reproducible:

Reproducible every time by doing the following:

1. Create a dummy init.d script containing the following

#!/bin/sh
#
# chkconfig: 235 99 11
# Description: dummy

2. Run the following command

# chkconfig dummy on

3. Confirmed that only start script symlinks were created by doing a find from /etc

Checking the /etc/rc3.d directory has only the start script symlink and no kill scripts.

  
Actual results:

Only start scripts created 

Expected results:

Start and Stop scripts should be created

Additional info:
Comment 1 David Hartmann 2010-06-14 00:51:00 EDT
The command used to create the symlink was incorrect "chkconfig --add <scriptname>" I think should have been used.

The result is still the same with only start scripts created. I am unable to get both start and stop scripts created as in the init.d script
Comment 2 Bill Nottingham 2010-06-15 15:33:57 EDT
[root@localhost init.d]# cat /etc/init.d/dummy 
#!/bin/sh 
# 
# chkconfig: 235 11 99 
# Description: dummy 
[root@localhost init.d]# chkconfig --add dummy 
[root@localhost init.d]# ls /etc/rc*.d/*dummy 
/etc/rc0.d/K99dummy /etc/rc3.d/S11dummy /etc/rc6.d/K99dummy                    
/etc/rc1.d/K99dummy /etc/rc4.d/K99dummy              
/etc/rc2.d/S11dummy /etc/rc5.d/S11dummy              
[root@localhost init.d]# rpm -q chkconfig
chkconfig-1.3.30.2-2.el5

This works for me.

Note You need to log in before you can comment on or make changes to this bug.