Bug 603616 - device mapper refuses to revive device despite the physical path being available
Summary: device mapper refuses to revive device despite the physical path being available
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: device-mapper-multipath
Version: 5.5
Hardware: All
OS: Linux
urgent
urgent
Target Milestone: rc
: ---
Assignee: Ben Marzinski
QA Contact: Red Hat Kernel QE team
URL:
Whiteboard:
Keywords: Regression, ZStream
Depends On: 599053
Blocks: 556823 603130
TreeView+ depends on / blocked
 
Reported: 2010-06-14 07:38 UTC by RHEL Product and Program Management
Modified: 2013-01-11 03:04 UTC (History)
25 users (show)

(edit)
Due to the inability of multipathd (a path monitoring daemon) to distinguish between deleted and recently added but not yet fully initialized devices, it used to take more than a minute to remove a dead path and reload the device with a new one. This has been fixed and multipathd now removes the deleted devices immediately.
Clone Of:
(edit)
Last Closed: 2010-07-14 12:44:00 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2010:0532 normal SHIPPED_LIVE device-mapper-multipath bug fix update 2010-07-14 12:43:58 UTC

Description RHEL Product and Program Management 2010-06-14 07:38:13 UTC
This bug has been copied from bug #599053 and has been proposed
to be backported to 5.5 z-stream (EUS).

Comment 4 Ben Marzinski 2010-06-14 21:06:32 UTC
zstream packages built.

Comment 5 Jaromir Hradilek 2010-06-25 14:49:48 UTC
Technical note added. If any revisions are required, please edit the "Technical Notes" field
accordingly. All revisions will be proofread by the Engineering Content Services team.

New Contents:
Due to the inability of multipathd (a path monitoring daemon) to distinguish between deleted and recently added but not yet fully initialized devices, it used to take more than a minute to remove a dead path and reload the device with a new one. This has been fixed and multipathd now removes the deleted devices immediately.

Comment 6 Barry Donahue 2010-06-30 14:26:26 UTC
Verified again on device-mapper-multipath-0.4.7-34.el5_5.4.x86_64.rpm kpartx-0.4.7-34.el5_5.4.x86_64.rpm

Comment 10 errata-xmlrpc 2010-07-14 12:44:00 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2010-0532.html


Note You need to log in before you can comment on or make changes to this bug.