Bug 603712 - wrong license
Summary: wrong license
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: hyphen-bg (Show other bugs)
(Show other bugs)
Version: 6.0
Hardware: All Linux
low
medium
Target Milestone: rc
: ---
Assignee: Caolan McNamara
QA Contact: desktop-bugs@redhat.com
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-06-14 12:23 UTC by David Tardon
Modified: 2010-06-14 12:57 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-14 12:57:02 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description David Tardon 2010-06-14 12:23:31 UTC
Description of problem:
http://bgoffice.sourceforge.net/license.html says the project is released under GPL 2 or better and the COPYRIGHT file in the package is for GPL 2. We currently have GPL+.

Version-Release number of selected component (if applicable):
hyphen-bg-4.1-4.1.el6

How reproducible:
always

Comment 2 RHEL Product and Program Management 2010-06-14 12:42:55 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.

Comment 3 Caolan McNamara 2010-06-14 12:48:01 UTC
Its unfortunately a little messy in 4.1, bgoffice 4.2 is more clear, that one says specifically in the documentation that "This package is distributed under the terms of either GNU General Public License Version 2 or later, or GNU Lesser General Public License Version 3 or later, or the Mozilla Public License Version 1.1.". 

For 4.1 though, this is not so clear, i.e. see
 
https://fedoraproject.org/wiki/Licensing/FAQ#How_do_I_figure_out_what_version_of_the_GPL.2FLGPL_my_package_is_under.3F

I don't think we can be sure that the current state of the web page URL reflects the older source package, so we fall into category 4, and the issue is resolved in bgoffice 4.2

Comment 4 David Tardon 2010-06-14 12:57:02 UTC
Ah, okay.


Note You need to log in before you can comment on or make changes to this bug.