Bug 603745 - [abrt] abrt-gui-1.1.5-1.el6: PluginSettingsUI.py:26:__init__:AttributeError: PluginSettingsUI instance has no attribute 'dialog'
Summary: [abrt] abrt-gui-1.1.5-1.el6: PluginSettingsUI.py:26:__init__:AttributeError: ...
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: abrt (Show other bugs)
(Show other bugs)
Version: 6.0
Hardware: x86_64 Linux
low
medium
Target Milestone: rc
: ---
Assignee: Denys Vlasenko
QA Contact: Michal Nowak
URL:
Whiteboard: abrt_hash:8956354c
Keywords:
Depends On:
Blocks: 584568 607028
TreeView+ depends on / blocked
 
Reported: 2010-06-14 13:29 UTC by Michal Nowak
Modified: 2013-03-08 02:10 UTC (History)
8 users (show)

Fixed In Version: abrt-1.1.6-1.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-10 19:33:11 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (688 bytes, text/plain)
2010-06-14 13:29 UTC, Michal Nowak
no flags Details

Description Michal Nowak 2010-06-14 13:29:16 UTC
abrt version: 1.1.5
architecture: x86_64
cmdline: /usr/bin/python /usr/share/abrt/CCMainWindow.py
component: abrt
executable: /usr/share/abrt/CCMainWindow.py
kernel: 2.6.32-33.el6.x86_64
package: abrt-gui-1.1.5-1.el6
reason: PluginSettingsUI.py:26:__init__:AttributeError: PluginSettingsUI instance has no attribute 'dialog'
release: Red Hat Enterprise Linux release 6.0 Beta (Santiago)
time: 1276521925
uid: 500

backtrace
-----
PluginSettingsUI.py:26:__init__:AttributeError: PluginSettingsUI instance has no attribute 'dialog'

Traceback (most recent call last):
  File "/usr/share/abrt/CReporterAssistant.py", line 184, in on_config_plugin_clicked
    ui = PluginSettingsUI(plugin, parent=parent)
  File "/usr/share/abrt/PluginSettingsUI.py", line 26, in __init__
    self.dialog.set_position(gtk.WIN_POS_CENTER_ON_PARENT)
AttributeError: PluginSettingsUI instance has no attribute 'dialog'

Local variables in innermost frame:
pluginfo: <ABRTPlugin.PluginInfo instance at 0x110e8c0>
self: <PluginSettingsUI.PluginSettingsUI instance at 0x110ecb0>
parent: <gtk.Dialog object at 0x11277d0 (GtkDialog at 0x132c0a0)>

How to reproduce
-----
1. set rhticket as one of reporters for all handlers in abrt.conf
2. crashed `sleep` -> Report -> [x] rhticket
3. window with "Wrong credentials" popped up
4. clicked button to set them - got this  traceback

Comment 1 Michal Nowak 2010-06-14 13:29:18 UTC
Created attachment 423833 [details]
File: backtrace

Comment 3 Michal Nowak 2010-06-14 13:32:21 UTC
"Configure Plugin" is greyed out in Plugins window.

Comment 4 Michal Nowak 2010-06-14 13:40:19 UTC
When I say "No" to "Wrong credentials" it works as expected; http://support-services-devel.gss.redhat.com:8080/Strata/cases/00009620.

Comment 5 Michal Nowak 2010-06-14 13:49:07 UTC
Err I should have said:

When I say "Yes" to "Wrong credentials" it works as expected.

Comment 6 Denys Vlasenko 2010-06-15 16:03:49 UTC
This also seems to be fixed in git by today's changes. Will be in abrt-1.1.6.
Note that rhticket plugin got renamed to RHTSupport in 1.1.6.

Comment 8 releng-rhel@redhat.com 2010-11-10 19:33:11 UTC
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.


Note You need to log in before you can comment on or make changes to this bug.