Bug 60377 - NIS Makefile overwritten during upgrade
NIS Makefile overwritten during upgrade
Status: CLOSED DUPLICATE of bug 57078
Product: Red Hat Linux
Classification: Retired
Component: ypserv (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Alexander Larsson
Aaron Brown
:
: 62895 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-02-26 18:24 EST by Hunter Matthews
Modified: 2007-04-18 12:40 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-21 11:00:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hunter Matthews 2002-02-26 18:24:29 EST
Description of Problem:
The makefile (/var/yp/Makefile) does not appear to be treated as a config
file, and it really is.

Here in biology, we've added several tables for the automounter, chosen 
not to use shadow passwords, etc etc. 

So, when I upgraded our NIS server, imagine my .... surprise to discover 
that the first make after adding a new group results in a broken NIS for 
the department.

Version-Release number of selected component (if applicable):
ypserv 1.3.12-2

However, I note that in a verify:
[root@pogonia yp]# rpm -V ypserv
....L...   /var/yp
SM5....T c /var/yp/Makefile
SM5...GT c /var/yp/securenets

That the makefile is marked as a config file. However, rpm (during the 
anaconda upgrade from RH 7.1) most definately did not create an rpmsave or 
rpmnew file.
Comment 1 Florian La Roche 2002-03-10 07:19:46 EST
/var/yp/Makefile is marked as %config, so everything should be fine.

Thanks,

Florian La Roche
Comment 2 Hunter Matthews 2002-03-11 10:36:19 EST
Yes, which I noted in the bug report. 


Care to comment why we had a problem then? Did you try it? Or just make it 
WORKSFORME after reading the spec file?
Comment 3 Alexander Larsson 2002-03-21 11:00:44 EST
This seems to be reported in 20106 too.
Comment 4 Alexander Larsson 2002-03-22 10:06:51 EST
This is in fact a bug in rpm.


*** This bug has been marked as a duplicate of 57078 ***
Comment 5 Alexander Larsson 2002-04-07 17:42:11 EDT
*** Bug 62895 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.