Bug 603789 - RFE: Add support for customizing fields returned in bugzilla whine reports
Summary: RFE: Add support for customizing fields returned in bugzilla whine reports
Status: CLOSED WONTFIX
Alias: None
Product: Bugzilla
Classification: Community
Component: Whining (Show other bugs)
(Show other bugs)
Version: 3.6
Hardware: All Linux
low
medium vote
Target Milestone: ---
Assignee: Simon Green
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-06-14 15:19 UTC by Perry Myers
Modified: 2014-10-12 22:46 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-20 04:26:27 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Perry Myers 2010-06-14 15:19:57 UTC
Description of problem:
Presently bz Whine reports contain a static set of fields that are returned including: bug #, link, prio, assignee, status, summary

But it would be useful for people to be able to customize these fields to add other fields of interest like: flags, component name

Comment 1 David Lawrence 2010-06-14 15:28:44 UTC
Currently the whine emails come from a static template and contain a preset list of bug fields. Changes to Bugzilla to allow per-user configuration of these fields will not be trivial as there will need to be DB changes as well as a new UI to support it. Are there any specific Bugzilla fields/values that we can 
add today to the static template that would help you and others until we get time/resources to do this the right way?

Dave

Comment 2 Perry Myers 2010-06-14 16:14:17 UTC
Absolutely.  The biggest thing for me is Product/Component.  If those could be added that would probably help a lot of people.

Flags would also be useful for some mgmt folks, but since there is ack-viewer tool it's probably not as critical and also not as generically useful.

So if you could add Product/Component that would be great!

Comment 3 David Lawrence 2010-06-14 21:29:20 UTC
Added product and component and will be in the next update.

Comment 4 Jeff Fearn 2012-05-30 04:39:00 UTC
As part of the recent Bugzilla 2.4 upgrade the Bugzilla team are cleaning up bugs opened against old versions of Bugzilla. This bug has been flagged as an old bug and will be CLOSED WONTFIX in 7 days time.

If you believe this bug is an issue in the latest Bugzilla version please comment on this bug within 7 days. Doing so will ensure this bug is not closed automatically.

Thanks, the Bugzilla team.

Comment 5 Perry Myers 2012-05-30 12:22:39 UTC
I'm not presently using bz whines any longer, so I can't comment on whether or not this has been fixed.  Feel free to close the bug unless someone else is looking for this functionality

Comment 6 Simon Green 2012-06-20 04:26:27 UTC
(In reply to comment #5)
> Feel free to close the bug unless someone else
> is looking for this functionality


Note You need to log in before you can comment on or make changes to this bug.