Bug 603848 - Installing package(s) already installed causes kpackagekit to produces multiple messages
Installing package(s) already installed causes kpackagekit to produces multip...
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: kpackagekit (Show other bugs)
13
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Steven M. Parrish
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-14 13:05 EDT by Kyle Pablo
Modified: 2010-12-03 21:14 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-12-03 21:14:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Snapshot of multiple messages (386.99 KB, image/png)
2010-06-14 13:05 EDT, Kyle Pablo
no flags Details

  None (edit)
Description Kyle Pablo 2010-06-14 13:05:15 EDT
Created attachment 423913 [details]
Snapshot of multiple messages

Description of problem:
When I select a package that is already installed and click "apply" I get 30+ messages stating "Package already installed" and "Simulating the install."

Version-Release number of selected component (if applicable):
kpackagekit-0.6.0-2.fc13.x86_64

How reproducible:
Everytime

Steps to Reproduce:
1. Select an already installed package
2. click apply
3.
  
Actual results:
30+ messages stating "Package already installed" and "Simulating the install."

Expected results:
One message stating "Package already installed"? Need better message handling.

Additional info:

Note You need to log in before you can comment on or make changes to this bug.