Bug 604071 - kickstart is missing parameter during installation in kvm guest, error processing drive
kickstart is missing parameter during installation in kvm guest, error proces...
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: anaconda (Show other bugs)
6.0
All Linux
high Severity medium
: rc
: ---
Assigned To: Anaconda Maintenance Team
Release Test Team
: Regression
Depends On:
Blocks: 582655
  Show dependency treegraph
 
Reported: 2010-06-15 07:10 EDT by Petr Sklenar
Modified: 2010-06-25 03:26 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-24 15:12:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda error, screenshot (66.90 KB, image/jpeg)
2010-06-15 07:10 EDT, Petr Sklenar
no flags Details
anaconda.log (6.33 KB, text/plain)
2010-06-15 07:11 EDT, Petr Sklenar
no flags Details

  None (edit)
Description Petr Sklenar 2010-06-15 07:10:33 EDT
Created attachment 424116 [details]
anaconda error, screenshot

Description of problem:
cannot perform installation in kvm guest

Version-Release number of selected component (if applicable):
running anaconda 13.21.50
20100610.nightbuild

How reproducible:
always

Steps to Reproduce:
1. I have virtual kvm host, rhel55 and starting kvm guest , I allocated 4000Mb of disk space , type vda
2. start installation of rhel6 - 20100610.nightbuild
3. error processing drive, clicking re-initializing  
  
Actual results:
kickstart is missing parameter

Expected results:
disk is reinitialized 


Additional info:
Comment 1 Petr Sklenar 2010-06-15 07:11:22 EDT
Created attachment 424117 [details]
anaconda.log

anaconda.log from kvm guest
Comment 2 Petr Sklenar 2010-06-15 07:24:46 EDT
It happens only during PXE installation from local brno tree. http://download.englab.brq.redhat.com/pub/rhel/nightly/RHEL6.0-20100610.n.0/

If I start installation from http source in virt-manager, then it works well.
Comment 3 Chris Lumens 2010-06-16 09:53:48 EDT
Is your working install a graphical install and your non-working one is a text install?
Comment 4 Petr Sklenar 2010-06-16 11:15:02 EDT
(In reply to comment #3)
> Is your working install a graphical install and your non-working one is a text
> install?    
Issue in only in PXE text installation

Now I tried:
* PXE installation in virt-manager
graphical - works well , I can install rhel6
text installation - non-working, issue from Comment 0

* http source in virt-manager
the both graphical and text works well.
Comment 5 Chris Lumens 2010-06-17 10:04:32 EDT
And does your kickstart file specify any partitioning information?  If you can attach the complete file, that'd be great.
Comment 6 Petr Sklenar 2010-06-17 11:59:54 EDT
it would be this one: http://10.34.32.211/cblr/svc/op/ks/profile/RHEL6.0-20100610.n.0_http-Server-x86_64  (from anaconda.log)

its installing from Brno pxe server, and I have no idea how could I find which ks is using
Comment 7 Chris Lumens 2010-06-24 15:12:33 EDT
What appears to be happening here is that due to too little memory in your virtual machine (see "10:54:47,493 WARNING : You do not have enough RAM to use the graphical installer.  Starting text mode." from your anaconda.log), you are being forced into a text install.  Your kickstart file does not specify any bootloader or packaging sections.  This therefore means anaconda needs to stop and prompt for these elements.

However, the text installer has been stripped down to no longer include any custom partitioning, bootloader configuration, or package selection.  Therefore, the installation halts because the code to prompt for this information does not exist.  It looks to me like everything is working as expected here.
Comment 8 Petr Sklenar 2010-06-25 03:26:40 EDT
(In reply to comment #7)
> What appears to be happening here is that due to too little memory in your
> virtual machine (see "10:54:47,493 WARNING : You do not have enough RAM to use
> the graphical installer.  Starting text mode." from your anaconda.log), you are

yes, my guest had 444MB, so you are going to say that pxe installation is not working and installation from http source is working for low mem guests, right?

Note You need to log in before you can comment on or make changes to this bug.