Bug 604075 - FormatCreateError: ('invalid device specification', '/dev/dasda2')
Summary: FormatCreateError: ('invalid device specification', '/dev/dasda2')
Status: CLOSED DUPLICATE of bug 601855
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: anaconda (Show other bugs)
(Show other bugs)
Version: 6.0
Hardware: s390x Linux
low
medium
Target Milestone: rc
: ---
Assignee: Brian Lane
QA Contact: Release Test Team
URL:
Whiteboard:
Keywords: Reopened
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-06-15 11:18 UTC by Hendrik Brueckner
Modified: 2011-06-10 16:11 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-06-10 16:11:28 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
logs.tgz (1.20 MB, application/x-compressed-tar)
2010-06-23 17:31 UTC, IBM Bug Proxy
no flags Details
FBA installation (52.37 KB, image/jpeg)
2010-07-30 11:23 UTC, IBM Bug Proxy
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
IBM Linux Technology Center 65029 None None None Never

Description Hendrik Brueckner 2010-06-15 11:18:28 UTC
The following was filed automatically by anaconda:
anaconda 13.21.50 exception report
Traceback (most recent call first):
  File "/tmp/updates/storage/formats/__init__.py", line 265, in create
    raise FormatCreateError("invalid device specification", self.device)
  File "/tmp/updates/storage/formats/swap.py", line 168, in create
    DeviceFormat.create(self, *args, **kwargs)
  File "/tmp/updates/storage/deviceaction.py", line 288, in execute
    options=self.device.formatArgs)
  File "/tmp/updates/storage/devicetree.py", line 700, in processActions
    action.execute(intf=self.intf)
  File "/tmp/updates/storage/__init__.py", line 293, in doIt
    self.devicetree.processActions()
  File "/usr/lib/anaconda/packages.py", line 109, in turnOnFilesystems
    anaconda.id.storage.doIt()
  File "/usr/lib/anaconda/dispatch.py", line 208, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 126, in gotoNext
    self.moveStep()
  File "/tmp/updates/gui.py", line 1334, in nextClicked
    self.anaconda.dispatch.gotoNext()
FormatCreateError: ('invalid device specification', '/dev/dasda2')

Comment 2 RHEL Product and Program Management 2010-06-15 11:33:20 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.

Comment 3 Chris Lumens 2010-06-16 14:31:19 UTC
Can you please attach the complete /tmp/*tb* file to this bug report?

Comment 4 David Cantrell 2010-06-22 19:40:46 UTC
If you can provide the information requested in comment 3, please attach it to the bug and reopen.

Comment 5 IBM Bug Proxy 2010-06-23 17:23:19 UTC
Reopening to provide the requested data...

Comment 6 IBM Bug Proxy 2010-06-23 17:30:58 UTC
------- Comment From michael.holzheu@de.ibm.com 2010-06-15 07:39 EDT-------
Description of problem:

Version-Release number of selected component (if applicable):

How reproducible:

Use one DASD with 5120 MB

Steps to Reproduce:
1. Use "specialized storage devices" -> next
2. Select DASD -> next
3. Specify host name -> next
4. Select time zone (NOTE SELECTING CITY IS REALLY NOT USER FRIENDLY) -> next
5. Enter passwd -> next
6. Select "Create Custom Layout" -> next
7. Create
8. Select standard partition -> create
9. mount point=/home, size=2000MB, fixed size, fs=ext4 -> ok
10. Select standard partition -> create
11. size=2000MB, fixed size, fs=swap -> ok
12. Select standard partition -> create
13. mount point=/, (size=200), fill to maximum allowable size, fs=ext4 -> ok
14. Overview looks ok -> next
15. -> Write changes to disk
16. ERROR: Formatting failed (an error was encountered while formatting device /dev/dasda2)
Details: Invalid device specification

-> Exit intaller

Actual results:

Installation fails

Expected results:

Installation works

------- Comment From michael.holzheu@de.ibm.com 2010-06-15 07:55 EDT-------
Problem is that I have a FBA disk.

Bus-ID     Status      Name      Device  Type  BlkSz  Size      Blocks
==============================================================================
0.0.4712   active      dasda     94:0    FBA   512    5120MB    10485760

It is not possible to create partitions on FBA DASDs.

------- Comment From michael.holzheu@de.ibm.com 2010-06-15 08:00 EDT-------
It is also not possible to specify only one partition "/" in order to use only dasda1 from the FBA disk.
I get the error:

mount failed: (9,None)

------- Comment From brueckner@linux.vnet.ibm.com 2010-06-21 04:28 EDT-------
Hi Luciano,

(In reply to comment #5)
> So is https://bugzilla.redhat.com/show_bug.cgi?id=604075 supposed to be mapped
> to this bug? Why couldn't we forward mirror as usual to RHIT? At the moment Red
> Hat is getting pretty strict on the content of the bugs we send over. However,
> if there is a prior agreement that these bugs are supposed to go directly to
> RHBZ as opposed to RHIT then please let me know. Thanks.

Could you reverse mirror and attach the bug mentioned above to this one.  The information you suggested for RHIT are already available in the RH BZ as this has been automatically reported by anaconda.

Further please attach the logs.tgz to the RHBZ as this has been requested by anaconda team. Please also clear the NEEDINFO flag which is currently set for me.

Thanks.

Comment 7 IBM Bug Proxy 2010-06-23 17:31:16 UTC
Created attachment 426322 [details]
logs.tgz


------- Comment on attachment From michael.holzheu@de.ibm.com 2010-06-15 07:40 EDT-------


Additional info:  
- Please create the following tar archive and contact your bug assistant:
tar --exclude=/tmp/install.img -cvzf /logs.tgz /tmp /etc

Comment 9 IBM Bug Proxy 2010-07-20 07:11:24 UTC
------- Comment From Praveen.Pandey@in.ibm.com 2010-07-20 03:05 EDT-------
I check it on RHEL6.0 snap7 but I provide the normal DASD it having 7043 M.B space and go through all the reproducible steps and I do not find any issue means all installation works fine and also rebooting system it is boot able .

If there is any issue regarding the DASD memory.Please clear that.

Comment 10 IBM Bug Proxy 2010-07-20 09:31:53 UTC
------- Comment From michael.holzheu@de.ibm.com 2010-07-20 05:29 EDT-------
Just to be sure: Have you used an FBA DASD?
What shows lsdasd?

Comment 11 IBM Bug Proxy 2010-07-30 06:01:52 UTC
------- Comment From Praveen.Pandey@in.ibm.com 2010-07-30 01:50 EDT-------
I also verified it on RHEL6.0 snap8 but I provide the normal DASD it having 7043 M.B space and go through all the reproducible steps and I do not find any issue
means all installation works fine and also rebooting system is boot able .

Comment 12 IBM Bug Proxy 2010-07-30 07:21:24 UTC
------- Comment From Praveen.Pandey@in.ibm.com 2010-07-30 03:17 EDT-------
reply to comment #12

I am not using FBA DASD.

Log :

[root@h0530019 ~]# lsdasd
Bus-ID     Status      Name      Device  Type  BlkSz  Size      Blocks
==============================================================================
0.0.5d36   active      dasda     94:0    ECKD  4096   7043MB    1803060

Comment 13 IBM Bug Proxy 2010-07-30 09:21:15 UTC
------- Comment From michael.holzheu@de.ibm.com 2010-07-30 05:14 EDT-------
FBA DASDs are not working. Please test with FBA.
You can define a temporary FBA dasd as follows:
#cp def vfb-512 <devno> <blocks>

Comment 14 IBM Bug Proxy 2010-07-30 11:23:19 UTC
------- Comment From Praveen.Pandey@in.ibm.com 2010-07-30 07:18 EDT-------
yes I verified it on RHEL6 snap8 using  FBA DASD ,bug is still there means going through all reproducible step.on formatting step it shows that

ERROR: Formatting failed (an error was encountered while formatting device
/dev/dasda2)

I also attach the sanpshot ..

Comment 15 IBM Bug Proxy 2010-07-30 11:23:23 UTC
Created attachment 435530 [details]
FBA installation


------- Comment (attachment only) From Praveen.Pandey@in.ibm.com 2010-07-30 07:19 EDT-------

Comment 17 David Lehman 2010-09-28 14:42:10 UTC
This looks like it might well be fixed by the parted patches from 629791 (and 634980).

Comment 18 Brian Lane 2010-09-28 16:36:00 UTC
Fedora 14 uses parted 2.3 which is significantly different from parted 2.2 used in RHEL6 so those patches likely won't apply here. 

Can you partition the FBA DASD using fdisk or other tools from tty2 and then only format them using Anaconda? I'm trying to understand what is supposed to be possible with these devices and where the core problem lies.

Comment 19 RHEL Product and Program Management 2010-11-16 00:49:33 UTC
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux maintenance release. Product Management has 
requested further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed 
products. This request is not yet committed for inclusion in an Update release.

Comment 20 Jan Stodola 2010-11-16 16:23:18 UTC
Brian, I partitioned FBA DASD before starting vnc session:

[anaconda root@rtt6 root]# lsdasd 
Bus-ID     Status      Name      Device  Type  BlkSz  Size      Blocks
==============================================================================
0.0.eeee   active      dasdb     94:4    FBA   512    953MB     1953128
[anaconda root@rtt6 root]# parted /dev/dasdb
GNU Parted 2.1
Using /dev/dasdb
Welcome to GNU Parted! Type 'help' to view a list of commands.
(parted) mklabel                                                          
New disk label type? dasd                                                 
Warning: The existing disk label on /dev/dasdb will be destroyed and all data on this disk will be lost. Do you want to continue?
Yes/No? yes                                                               
Error: fdasd: Unsupported disk type -- This is not an ECKD disk!  This disk type is not supported!

(parted) mklabel                                                          
New disk label type? msdos                                                
Warning: The existing disk label on /dev/dasdb will be destroyed and all data on this disk will be lost. Do you want to continue?
Yes/No? YES                                                               
(parted) mkpart primary 0 900                                             
(parted) quit                                                             
Information: You may need to update /etc/fstab.


During the installation I only formatted /dev/dasdb1 as ext4 and mounted it as /. Installation failed when writing changes to disk with message:
An error occurred mounting device /dev/dasdb1 as /:
mount failed: (9, None). This is a fatal error and the install
cannot continue.

Comment 22 Brian Lane 2011-01-11 00:17:49 UTC

*** This bug has been marked as a duplicate of bug 601855 ***

Comment 23 Georg Markgraf 2011-06-10 15:06:38 UTC
The Installer is the value-added code from Red Hat.
  - Red Hat have to maintain this differentiator for RHEL
  - System z cannot take ownership for the installer
For sure System z will offer help like in the past. 

If you want to track this via Fedora - fine but that makes no difference 

Although its obvious I re-call
  - it is very important that the installer get improved for our customers

Comment 24 Brian Lane 2011-06-10 16:11:28 UTC
(In reply to comment #23)
> The Installer is the value-added code from Red Hat.
>   - Red Hat have to maintain this differentiator for RHEL
>   - System z cannot take ownership for the installer
> For sure System z will offer help like in the past. 
> 
> If you want to track this via Fedora - fine but that makes no difference 
> 
> Although its obvious I re-call
>   - it is very important that the installer get improved for our customers

This bug has been closed as a duplicate of bug 601855, please do not reopen.

*** This bug has been marked as a duplicate of bug 601855 ***


Note You need to log in before you can comment on or make changes to this bug.