Bug 60410 - Bogus conflict with libpng10
Bogus conflict with libpng10
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: libpng10 (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: wdovlrrw
:
: 60423 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-02-27 10:25 EST by Sammy
Modified: 2008-05-01 11:38 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-05 15:16:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sammy 2002-02-27 10:25:53 EST
When trying to upgrade to libpng10-1.0.12-5 from libpng10-1.0.12-4
and having libpng-1.2.1-2 installed I get the following dependency error:

error: failed dependencies:
        libpng < 1.2.0 conflicts with libpng10-1.0.12-5
Comment 1 Bill Crawford 2002-02-27 17:36:42 EST
It conflicts with itself ;o)

[root@marcus RPMS]# rpm -Fvh *
error: failed dependencies:
        libpng < 1.2.0 conflicts with libpng10-1.0.12-5
[root@marcus RPMS]# ls *png*
kdegraphics-kfile-png-3.0.0-0.cvs20020129.1.i386.rpm 
libpng10-devel-1.0.12-5.i386.rpm
libpng10-1.0.12-5.i386.rpm
[root@marcus RPMS]# rpm -q libpng
libpng-1.2.1-2
[root@marcus RPMS]# rpm -q libpng10
libpng10-1.0.12-4
[root@marcus RPMS]# rpm -Uvh libpng10-*
error: failed dependencies:
        libpng < 1.2.0 conflicts with libpng10-1.0.12-5
[root@marcus RPMS]# rpm -qa | egrep png
libpng10-1.0.12-4
libpng-1.2.1-2
libpng10-devel-1.0.12-4
libpng-devel-1.2.1-2
[root@marcus RPMS]# rpm -q --provides libpng10
libpng = 1.0.12
libpng.so.2  
libpng10 = 1.0.12-4
[root@marcus RPMS]# rpm -qp --provides libpng10-
libpng10-1.0.12-5.i386.rpm        libpng10-devel-1.0.12-5.i386.rpm
[root@marcus RPMS]# rpm -qp --provides libpng10-1.0.12-5.i386.rpm 
libpng = 1.0.12
libpng.so.2  
libpng10 = 1.0.12-5
[root@marcus RPMS]# rm -f libpng10-*
Comment 2 Bernhard Rosenkraenzer 2002-03-04 05:50:33 EST
*** Bug 60423 has been marked as a duplicate of this bug. ***
Comment 3 Bernhard Rosenkraenzer 2002-03-04 12:57:53 EST
Provides: libpng = 1.0.12 
Conflicts: libpng = 1.0.12 
 
caused the package to conflict with itself. 
Fixed in -6.
Comment 4 Sammy 2002-03-05 15:16:15 EST
I just instaled -6 and gave the same error!
Comment 5 Bernhard Rosenkraenzer 2002-03-11 10:21:07 EST
Yuck. There are two different variants of -6 out there. The public one is broken, the 
internal one works. 
Looks like some part of rawhide generation is broken. In any case, the one that will be in 
a future release is correct.

Note You need to log in before you can comment on or make changes to this bug.