Bug 604101 - rhn_register, description 'See Kbase article 6227 for more details.' is wrong
Summary: rhn_register, description 'See Kbase article 6227 for more details.' is wrong
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: rhn-client-tools   
(Show other bugs)
Version: 6.0
Hardware: All Linux
low
medium
Target Milestone: rc
: ---
Assignee: Milan Zázrivec
QA Contact: Petr Sklenar
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 582655
TreeView+ depends on / blocked
 
Reported: 2010-06-15 12:44 UTC by Petr Sklenar
Modified: 2010-11-10 21:30 UTC (History)
1 user (show)

Fixed In Version: rhn-client-tools-1.0.0-24.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-10 21:30:12 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot with wrong kbase number (182.62 KB, image/jpeg)
2010-06-15 12:44 UTC, Petr Sklenar
no flags Details

Description Petr Sklenar 2010-06-15 12:44:02 UTC
Created attachment 424137 [details]
screenshot with wrong kbase number

Description of problem:
There is message 'See Kbase article 6227 for more details.' after registering - screen 'Review system subscription details'

Version-Release number of selected component (if applicable):
rhn-client-tools-1.0.0-14.el6.noarch

How reproducible:
always

Steps to Reproduce:
1. rhn_register
2. register with some account to errata.stage
3. see screen 'Review system subscription details' and there is message: 'See Kbase article 6227 for more details.'
5. go to http://kbase.redhat.com/faq/en and search for 'DOC-6227'
  
Actual results:
This article is something different. Its about 'How do I make the 'Red Hat Enterprise Linux Test Page' go away in Apache?'. Its not related to registering. 

Expected results:
remove number 6227, for ex:

See Kbase article for more details. (http://kbase.redhat.com/faq/FAQ_58_6227.shtm)   

Additional info:
http://kbase.redhat.com/faq/docs/DOC-6227

Comment 1 Petr Sklenar 2010-06-15 12:46:26 UTC
or the number of kbase should be 11313
http://kbase.redhat.com/faq/docs/DOC-11313

Comment 2 RHEL Product and Program Management 2010-06-15 12:53:12 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.

Comment 4 Milan Zázrivec 2010-06-18 13:13:26 UTC
Interestingly, the link mentioned in the dialog works for me, I just
got redirected to http://kbase.redhat.com/faq/docs/DOC-11313

Not quite sure though how long will the redirection work ...

Comment 5 Petr Sklenar 2010-06-18 13:44:33 UTC
(In reply to comment #4)
> Interestingly, the link mentioned in the dialog works for me, I just
> got redirected to http://kbase.redhat.com/faq/docs/DOC-11313
> 
> Not quite sure though how long will the redirection work ...    

http://kbase.redhat.com/faq/FAQ_58_6227.shtm is redirect to http://kbase.redhat.com/faq/docs/DOC-11313

but this (small) issue is only that sentence before is "See Kbase article 6227 for more details".
And searching for 'DOC-6227' in http://kbase.redhat.com/faq/en finds some Apache howto.

Comment 6 Milan Zázrivec 2010-06-18 14:23:35 UTC
(In reply to comment #5)
> (In reply to comment #4)
> > Interestingly, the link mentioned in the dialog works for me, I just
> > got redirected to http://kbase.redhat.com/faq/docs/DOC-11313
> > 
> > Not quite sure though how long will the redirection work ...    
> 
> http://kbase.redhat.com/faq/FAQ_58_6227.shtm is redirect to
> http://kbase.redhat.com/faq/docs/DOC-11313
> 
> but this (small) issue is only that sentence before is "See Kbase article 6227
> for more details".
> And searching for 'DOC-6227' in http://kbase.redhat.com/faq/en finds some
> Apache howto.    

Yup, I understand the problem you're describing. Searching for
DOC-6227 will lead you to strange documents.

Currently though, google search of 'redhat kbase 6227' will lead you to the
correct link (and redirection :-))

Nonetheless, I'm inclined to remove string "6227" from the dialog and replace
the http link with the current one, although I don't know how long will
the new link last ...

Comment 7 Milan Zázrivec 2010-06-21 12:13:22 UTC
spacewalk.git master: 25b7760e6be6dc779e0bee3564c9f4fb590f8af5
satellite.git CLIENT-RHEL-6: 467a5a3328c2b682bf6656ab5881e0a952c28980

Comment 8 Milan Zázrivec 2010-06-22 09:35:16 UTC
spacewalk.git master: 76dcdcdff053a9143739cb8d501b65354e3473bf
satellite.git CLIENT-RHEL-6: 726a44e01f106c49a895425061905a38185bbee1

Comment 10 Petr Sklenar 2010-07-12 09:09:29 UTC
now there is:
Warning: If an installed product on this system is not listed above, you will not receive updates or support for that product. If you would like to receive updates for that product, please login to your satellite web interface and subscribe this system to the appropriate software channels to get updates for that product. See Kbase article 11313 for more details. (http://kbase.redhat.com/faq/docs/DOC-11313)       

And link shows article 'How do I subscribe a system to a sub-channel or a child channel using Red Hat Network (RHN)?'
Searching for DOC 11313 in kbase finds the same.
--
Verified with rhn-client-tools-1.0.0-27.el6.noarch

Comment 11 releng-rhel@redhat.com 2010-11-10 21:30:12 UTC
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.


Note You need to log in before you can comment on or make changes to this bug.