Bug 60411 - gdm does not display logo on root window after X 4.1 upgrade
gdm does not display logo on root window after X 4.1 upgrade
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: xinitrc (Show other bugs)
7.1
i686 Linux
medium Severity low
: ---
: ---
Assigned To: Mike A. Harris
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-02-27 10:39 EST by John Dalbec
Modified: 2007-04-18 12:40 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-04 10:40:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Dalbec 2002-02-27 10:39:00 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.79 [en] (Windows NT 5.0; U)

Description of problem:
I upgraded X to the latest errata (4.1) and the shadow man logo no longer displays on the root window in gdm while the greeter is running.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.  Install gdm.
2.  Set DESKTOP=GNOME in /etc/sysconfig/desktop.
3.  Install XFree86 4.1.0 update.
	

Actual Results:  Featureless blue background

Expected Results:  Shadow man logo should display on background

Additional info:

Some gdm log messages (with debugging turned on):
Feb 27 09:45:20 dalbec gdm[1179]: gdm_slave_session_stop: jpdalbec on :0
Feb 27 09:45:20 dalbec gdm[1179]: gdm_verify_cleanup: Closing session 134615552
Feb 27 09:45:20 dalbec gdm(pam_unix)[1179]: session closed for user jpdalbec
Feb 27 09:45:21 dalbec gdm[1179]: gdm_auth_user_remove: Removing cookie from
/home/jpdalbec/.Xauthority (0)
Feb 27 09:45:21 dalbec gdm[1179]: gdm_auth_purge: :0
Feb 27 09:45:21 dalbec gdm[1179]: gdm_slave_session_cleanup: jpdalbec on :0
Feb 27 09:45:21 dalbec gdm[1179]: gdm_slave_xsync_ping: Pinging :0
Feb 27 09:45:21 dalbec gdm[1179]: gdm_slave_xsync_ping: :0 returned 1
Feb 27 09:45:21 dalbec gdm[1179]: gdm_slave_session_cleanup: Running post session script
Feb 27 09:45:21 dalbec gdm[1179]: gdm_slave_session_cleanup: Killing windows
Feb 27 09:45:21 dalbec gdm[1179]: gdm_slave_windows_kill: Could not open display :0
Feb 27 09:45:21 dalbec gdm[907]: gdm_child_handler: child 1179 returned 2
Feb 27 09:45:21 dalbec gdm[907]: gdm_child_handler: :0
Feb 27 09:45:21 dalbec gdm[907]: gdm_server_restart: Server for :0 restarting!
Feb 27 09:45:21 dalbec gdm[907]: gdm_server_start: :0
Feb 27 09:45:21 dalbec gdm[907]: Resetting counts for loop of death detection, 90 seconds
elapsed.
Feb 27 09:45:21 dalbec gdm[907]: Attempting to start X server
Feb 27 09:45:21 dalbec gdm[907]: gdm_server_start: Old server found (1178). Killing.
Feb 27 09:45:21 dalbec gdm[907]: gdm_server_stop: Server for :0 going down!
Feb 27 09:45:21 dalbec gdm[907]: gdm_auth_secure_display: Setting up access for :0
Feb 27 09:45:21 dalbec gdm[907]: gdm_auth_secure_display: Setting up socket access
Feb 27 09:45:21 dalbec gdm[907]: gdm_auth_secure_display: Setting up network access
Feb 27 09:45:21 dalbec gdm[907]: gdm_auth_secure_display: Setting up access for :0 - 2 entries
Feb 27 09:45:21 dalbec gdm[1393]: gdm_server_start: '/usr/bin/X11/X -auth /var/gdm/:0.Xauth
:0'
Feb 27 09:45:21 dalbec gdm[907]: gdm_server_usr1_handler: Starting display :0!
Feb 27 09:45:21 dalbec gdm[907]: gdm_display_manage: Managing :0
Feb 27 09:45:21 dalbec gdm[907]: gdm_display_manage: Forked slave: 1394
Feb 27 09:45:21 dalbec gdm[1394]: gdm_slave_start: Starting slave process for :0Feb 27
09:45:21 dalbec gdm[1394]: gdm_slave_start: Opening display :0
Feb 27 09:45:24 dalbec gdm[1394]: gdm_slave_greeter: Running greeter on :0
Feb 27 09:45:24 dalbec gdm[1394]: gdm_slave_greeter: Greeter on pid 1400
Feb 27 10:08:21 dalbec gdm(pam_unix)[1394]: session opened for user jpdalbec by (uid=0)
Feb 27 10:08:21 dalbec gdm[1394]: gdm_slave_greeter: Authentication completed. Whacking
greeter
Feb 27 10:08:21 dalbec gdm[1394]: gdm_slave_windows_kill: Killing windows on :0
Feb 27 10:08:21 dalbec gdm[1394]: gdm_slave_session_start: jpdalbec on :0
Feb 27 10:08:22 dalbec gdm[1394]: gdm_auth_user_add: Adding cookie for 500
Feb 27 10:08:22 dalbec gdm[1394]: gdm_auth_user_add: Using /home/jpdalbec/.Xauthority for
cookies
Feb 27 10:08:22 dalbec gdm[1394]: gdm_auth_purge: :0
Feb 27 10:08:22 dalbec gdm[1394]: gdm_auth_user_add: Done
Feb 27 10:08:22 dalbec gdm[1407]: Running /etc/X11/gdm/Sessions//Default for jpdalbec on :0
Comment 1 Havoc Pennington 2002-02-27 11:00:08 EST
What if you restart the X server? (Just hit Ctrl-Alt-Backspace on the gdm screen)

The logo normally disappears if you switch to a virtual console, unless we fixed
that in 7.2, which is possible, I forget.
Comment 2 John Dalbec 2002-03-01 17:04:09 EST
Sorry for the delay.  I wanted to double-check on a machine without the VMware tools installed.  I installed the X 4.1 upgrade and (since these machines are servers, 
rebooting them is awkward) service xfs stop; service xfs start; ps fx; kill <parent gdm process> (which is immediately restarted by init).  The shadow man logo and 
"redhat" in large letters are missing from the background.  I tried <Ctrl>-<Alt>-<Backspace> but no luck.  How does the logo (and "redhat") get there?  Maybe I can 
strace the appropriate process.
Comment 3 Havoc Pennington 2002-03-01 17:32:09 EST
The logo comes from "xsri" which is run by gdm, I believe. See "gdmconfig" on
the background tab there's a place to configure the xsri command.

We used to run xsri out of the X scripts (package xinitrc) but I don't think
that was true for 7.2
Comment 4 John Dalbec 2002-03-04 10:33:16 EST
I guess I could mark this CURRENTRELEASE but I don't think an update for 7.1 should break 7.1 behavior.
Changing component to xinitrc.
Comment 5 John Dalbec 2002-03-04 10:39:58 EST
The xinitrc-3.20-1 RPM (listed as an update for RH 7.1) assumes the RH 7.2 versions of gdm and xsri.
Comment 6 Mike A. Harris 2002-05-21 04:08:34 EDT
I consider this issue quite trivial, and not worthy of spending time on
considering much more pressing bugs.

Note You need to log in before you can comment on or make changes to this bug.