Bug 60412 - iputils has wrong defs for SOCK_STREAM and SOCK_DGRAM when building for MIPS
iputils has wrong defs for SOCK_STREAM and SOCK_DGRAM when building for MIPS
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: iputils (Show other bugs)
7.2
mips32 Linux
medium Severity medium
: ---
: ---
Assigned To: Phil Knirsch
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-02-27 10:53 EST by Ken Cox
Modified: 2015-03-04 20:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-07 10:11:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Path file that fixes problem (882 bytes, patch)
2002-02-27 10:54 EST, Ken Cox
no flags Details | Diff
patch to the spec file to apply the patch (695 bytes, patch)
2002-02-27 10:56 EST, Ken Cox
no flags Details | Diff

  None (edit)
Description Ken Cox 2002-02-27 10:53:11 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.2.1) Gecko/20010901

Description of problem:
When cross compiling the iputils package for a MIPS platform, iputils uses it's
own version of socket.h instead of using the one out of the toolchain and the
#defines for SOCK_STREAM and SOCK_DGRAM are wrong for a MIPS platform.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Cross compile the package for MIPS
2.Test by trying to ping another host
3.ping exits with a "Connection Refused" error
	

Actual Results:  When trying to open a "STREAM" (tcp) socket, a DGRAM (udp)
socket is opened instead and vice-versa.

Additional info:

This was found when compiling the package for the Embedded Linux Developer's
Suite (ELDS).
Comment 1 Ken Cox 2002-02-27 10:54:34 EST
Created attachment 46800 [details]
Path file that fixes problem
Comment 2 Ken Cox 2002-02-27 10:56:54 EST
Created attachment 46801 [details]
patch to the spec file to apply the patch
Comment 3 Phil Knirsch 2002-03-07 10:11:35 EST
Will look into it... Might be fixed with the newest iputils package already...

Read ya, Phil
Comment 4 Phil Knirsch 2002-04-10 06:39:44 EDT
Fixed in current rawhide version (latest iputils upstream tarball already
contained the correct fix).

Read ya, Phil

Note You need to log in before you can comment on or make changes to this bug.