Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 604127 - knetworkmanager Manage Connections screen is empty
knetworkmanager Manage Connections screen is empty
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: knetworkmanager (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-15 09:29 EDT by Fred Wells
Modified: 2010-06-18 13:43 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-18 13:27:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Fred Wells 2010-06-15 09:29:00 EDT
Description of problem:

"Manage Connections" screen is empty.  Thus, unable to edit available connections.

Version-Release number of selected component (if applicable):

knetworkmanager-0.9-0.19.20100419.fc13.i686

How reproducible:

Always

Steps to Reproduce:
1. Login to KDE
2. Open knetworkmanager "Manage Connections" screen from systray
3. Observe empty list
  
Actual results:

Empty (wired) connection list.

Expected results:

List available network interfaces

Additional info:
Comment 1 Rex Dieter 2010-06-15 11:38:22 EDT
Click "Add"
Comment 2 Fred Wells 2010-06-15 17:59:30 EDT
Why would I click "Add"?  I'm not adding a new one.  I simply want to edit an existing one.  nm-app, system-config-network each list the available interfaces whereas knetworkmanager does not.
Comment 3 Thomas Janssen 2010-06-17 15:48:39 EDT
Maybe you could explain the actual problem.

The *wired* tab is always empty. If you have a cable in your box, it gets automatically connected with it trough boot time.
What needs to be edited there?
Comment 4 Rex Dieter 2010-06-17 15:58:34 EDT
I think the reporter's expectation is to see an entry appear automatically when a wired interface is present (to match what nm-applet does).  knm currently doesn't do that, since it currently distinguishes between automatic connections and 'managed' (aka customized) ones.

(Not that knm is particularly good at doing 'managed' connections, but that's a separate topic).

anyway, If I'm correct about this, I'm not sure there's much constructive point to keeping this wishlist/rfe open in rh bugzilla (as we likely won't be the ones implementing it).
Comment 5 Fred Wells 2010-06-18 09:40:41 EDT
Rex has it right.  The user's expectation is to be able to 'manage' (as its name implies) any existing connections as well as the ability to add new ones, as nm-applet does. As an example, what if a user wants to disable (not remove) eth0 altogether and enable wlan0??
Comment 6 Thomas Janssen 2010-06-18 13:27:58 EDT
I see. Well, i'm with Rex here. We will not be the ones implementing this feature.

If you want this feature implemented file a RFE with upstreams bugtracker. http://bugs.kde.org

I will close this bug as 'notabug', though, thank you for helping to make KDE/Fedora better!

Best Regards
Comment 7 Rex Dieter 2010-06-18 13:43:03 EDT
In the meantime, if you find knetworkmanager doesn't suit your needs, you can still use nm-applet if you wish,
http://fedoraproject.org/wiki/KDE/Using_nm_applet_instead_of_knetworkmanager

Note You need to log in before you can comment on or make changes to this bug.