Bug 60417 - partition ordering inconsistent w/ autopartition
partition ordering inconsistent w/ autopartition
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: aboot (Show other bugs)
7.3
alpha Linux
medium Severity medium
: ---
: ---
Assigned To: Beth Uptagrafft
Beth Uptagrafft
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-02-27 11:40 EST by Jeff Wiedemeier
Modified: 2007-04-18 12:40 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-03 03:18:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeff Wiedemeier 2002-02-27 11:40:58 EST
Description of Problem:

From one install to another (even on the same system with no hardware changes),
the partition ordering created by autopartition varies. Specifically, it appears
that /boot is always the first partition, but swap and / can be assigned in
either order.

Version-Release number of selected component (if applicable):

7.2 rc (0222.1 iso)

How Reproducible:

often

Steps to Reproduce:
1. start the installation multiple on the same system, allowing autopartition to
use the whole disk
2. in the review screen, note the partition ordering

Actual Results:

swap and / appear in either order, making guessing of which partition is the
root filesystem impossible (with 7.1 autopartitioning, root was always /dev/sda2
and swap was always /dev/sda3 with a single disk SCSI system)

Expected Results:

consistent, predictable ordering of partitions

Additional Information:
	
This has been seen on DS10, DS20, ES45...
Comment 1 Phil Copeland 2002-03-12 16:19:48 EST
Huh?
/boot is forced to be the first partition because of the old 0.7 problem of
addressing the disk beyond the 2Gb (was it 2 or 4?)  extent limit

I'm perhaps being nieve, but why is the ordering important to you?  after all,
autopartitioning is the 'I don't care, just make it work' option. People that do
care would probably want to manually setup the disk partitioning as they see
fit/expect.

Phil
=--=
Comment 2 Jeff Wiedemeier 2002-03-12 17:20:16 EST
Yes, autopartitioning is the "just make it work" option, but the consistent 
ordering in the past was extremely useful when people would ask questions 
like "I can't boot my system, what do I do?" With the current aboot, you can 
poke around the disk and find the right partitions, but knowing that an 
autopartitioned disk had the root filesystem as /dev/sda2 gave a big head 
start.

In any case, I guess I don't particularly care whether this is changed or not. 
I thought it was odd the two consectuve autopartitioned installs on the same 
system would choose different orders. 

Also, since it is different behavior than in the past, I wanted to call it 
out. If it's by design, fine. If it's a mistake...
Comment 3 Phil Copeland 2002-03-21 11:41:39 EST
Well,... I suppose a way around that would be to dump the location of / and
/boot into the comment field of aboot.conf

Perhaps that might help?

Phil
=--=
Comment 4 Phil Copeland 2002-04-03 03:18:41 EST
Umm any update? or shall we close this one?

Phil
=--=
Comment 5 Phil Copeland 2002-04-22 12:38:08 EDT
Closing....

Note You need to log in before you can comment on or make changes to this bug.