Bug 604207 - [abrt] gnome-terminal-2.31.3-2.el6: terminal_screen_get_profile: Process /usr/bin/gnome-terminal was killed by signal 11 (SIGSEGV)
Summary: [abrt] gnome-terminal-2.31.3-2.el6: terminal_screen_get_profile: Process /usr...
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: gnome-terminal   
(Show other bugs)
Version: 6.0
Hardware: i686 Linux
low
medium
Target Milestone: rc
: ---
Assignee: Tomáš Bžatek
QA Contact: desktop-bugs@redhat.com
URL:
Whiteboard: abrt_hash:d5dab8381c1ce864d348953aae4...
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-06-15 15:45 UTC by Ales Zelinka
Modified: 2015-03-03 22:49 UTC (History)
4 users (show)

Fixed In Version: gnome-terminal-2.31.3-3.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-10 20:34:35 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (16.66 KB, text/plain)
2010-06-15 15:45 UTC, Ales Zelinka
no flags Details
patch (643 bytes, patch)
2010-06-28 16:18 UTC, Matthias Clasen
no flags Details | Diff

Description Ales Zelinka 2010-06-15 15:45:08 UTC
abrt version: 1.1.4
architecture: i686
Attached file: backtrace
cmdline: gnome-terminal
component: gnome-terminal
crash_function: terminal_screen_get_profile
executable: /usr/bin/gnome-terminal
global_uuid: d5dab8381c1ce864d348953aae45da76f14ef857
kernel: 2.6.32-30.el6.i686
package: gnome-terminal-2.31.3-2.el6
rating: 4
reason: Process /usr/bin/gnome-terminal was killed by signal 11 (SIGSEGV)
release: Red Hat Enterprise Linux Workstation release 6.0 Beta (Santiago)

How to reproduce
-----
Unfortunately I can't reproduce it. What I did:
openned gnome-terminal with few tabs, detached one, closeed it, then change the active tab in the original terminal.

Comment 1 Ales Zelinka 2010-06-15 15:45:10 UTC
Created attachment 424200 [details]
File: backtrace

Comment 2 Ales Zelinka 2010-06-15 15:56:10 UTC
Ok, I've narrowed down the steps to reproduce this:

1) open 2 tabs in gnome-terminal
2) drag one tab, drop it into the terminal window (i.e. on itself) - this is what messes the terminal up
3) do any tab manipulation (click the other tab, drag and drop the same tab again, close any of the tabs,...)

Comment 4 RHEL Product and Program Management 2010-06-15 16:13:18 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.

Comment 5 Matthias Clasen 2010-06-28 16:18:51 UTC
Created attachment 427453 [details]
patch

Comment 8 Radek Lat 2010-08-17 12:24:03 UTC
Tested and Verified on gnome-terminal-2.31.3-4.el6.x86_64, moving to VERIFIED.

Comment 9 releng-rhel@redhat.com 2010-11-10 20:34:35 UTC
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.


Note You need to log in before you can comment on or make changes to this bug.