Bug 604261 - RCU callbacks stop being processed
RCU callbacks stop being processed
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.7
All Linux
urgent Severity high
: rc
: ---
Assigned To: Prarit Bhargava
Red Hat Kernel QE team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-15 14:23 EDT by Casey Dahlin
Modified: 2014-06-18 04:47 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-25 13:31:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Sysreport (489.28 KB, application/x-bzip2)
2010-08-04 09:25 EDT, Frank Hirtz
no flags Details

  None (edit)
Description Casey Dahlin 2010-06-15 14:23:57 EDT
Description of problem:
Customer noticed that mcelog processes were hanging rather than completing. Investigation revealed that most of the hung mcelog processes were waiting on mce_read_sem in the kernel, and the one holding this lock was in synchronize_kernel. To pass out of synchronize kernel an RCU callback needed to complete which was nearly 4000 entries away from the head of the RCU list on that CPU.

Version-Release number of selected component (if applicable):
2.6.9-68.9.ELmsdw.2smp

How reproducible:
Highly sporadic but recurring on customer side. No other known reproducers.

Steps to Reproduce:
1. Run mcelog in cron
2. Wait for large number of blocked mcelog processes to accumulate.
Comment 2 Issue Tracker 2010-08-03 12:01:10 EDT
Event posted on 08-03-2010 12:01pm EDT by fhirtz

Any luck, observations, thoughts? This has been quite quiet on our side
since the last test failure 


This event sent from IssueTracker by fhirtz 
 issue 336173
Comment 3 Prarit Bhargava 2010-08-03 14:37:14 EDT
(In reply to comment #2)
> Event posted on 08-03-2010 12:01pm EDT by fhirtz
> 
> Any luck, observations, thoughts? This has been quite quiet on our side
> since the last test failure 

I haven't seen anything like this -- can we get an sosreport from them as well?

P.
Comment 4 Frank Hirtz 2010-08-04 09:25:19 EDT
Created attachment 436536 [details]
Sysreport
Comment 5 Frank Hirtz 2010-08-04 09:29:01 EDT
Attached. Let me know if you have questions or need anything further.

Thanks,

Frank.
Comment 6 Frank Hirtz 2010-09-08 11:00:08 EDT
Any thoughts on this?
Comment 8 Prarit Bhargava 2011-02-01 08:46:47 EST
What type of load are they running?  Are they seeing anything else in dmesg?

Note You need to log in before you can comment on or make changes to this bug.