Bug 604440 - smb4k missing proper mount requires
Summary: smb4k missing proper mount requires
Status: CLOSED DUPLICATE of bug 574904
Alias: None
Product: Fedora
Classification: Fedora
Component: smb4k
Version: 13
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Marcin Garski
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-06-15 21:44 UTC by Scott Williams
Modified: 2010-06-21 10:53 UTC (History)
1 user (show)

(edit)
Clone Of:
(edit)
Last Closed: 2010-06-21 10:53:55 UTC


Attachments (Terms of Use)

Description Scott Williams 2010-06-15 21:44:49 UTC
Description of problem:

If user simply installs smb4k and does not have cifs-utils installed, the program opens with error message that the following are needed:

mount.cifs
umount.cifs

mount.cifs is provided by the cifs-utils, so this needs to be added by Requires: in the RPM.  umount.cifs does not exist in the Fedora repo, but I did ln -s umount umount.cifs and it works appropriately.  The best fix would be to fix this inane requirement in smb4k. 

Version-Release number of selected component (if applicable):

smb4k-0.10.4-2.fc13

How reproducible:

Every time

Steps to Reproduce:
1. yum install smb4k
2. run smb4k
  
Actual results:

User gets an error message when opening the program and cannot continue.

Expected results:

The package should faithfully handle dependencies needed to run.

Additional info:

Comment 1 Marcin Garski 2010-06-21 10:53:55 UTC

*** This bug has been marked as a duplicate of bug 574904 ***


Note You need to log in before you can comment on or make changes to this bug.